summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/libcarddav/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/libcarddav/debian')
-rw-r--r--ubuntu/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk7
-rw-r--r--ubuntu/_base/dependencies/libcarddav/debian/compat2
-rw-r--r--ubuntu/_base/dependencies/libcarddav/debian/control2
-rwxr-xr-xubuntu/_base/dependencies/libcarddav/debian/rules44
4 files changed, 52 insertions, 3 deletions
diff --git a/ubuntu/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk b/ubuntu/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk
index f36e3527c..aba508624 100644
--- a/ubuntu/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk
@@ -82,7 +82,7 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/ubuntu/_base/dependencies/libcarddav/debian/compat b/ubuntu/_base/dependencies/libcarddav/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/dependencies/libcarddav/debian/compat
+++ b/ubuntu/_base/dependencies/libcarddav/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/dependencies/libcarddav/debian/control b/ubuntu/_base/dependencies/libcarddav/debian/control
index cb394a2c6..1f8eee3bb 100644
--- a/ubuntu/_base/dependencies/libcarddav/debian/control
+++ b/ubuntu/_base/dependencies/libcarddav/debian/control
@@ -2,7 +2,7 @@ Source: libcarddav
Section: graphics
Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake-trinity, ninja-build, libcurl4-gnutls-dev, libglib2.0-dev
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, libcurl4-gnutls-dev, libglib2.0-dev
Standards-Version: 3.8.4
Package: libcarddav
diff --git a/ubuntu/_base/dependencies/libcarddav/debian/rules b/ubuntu/_base/dependencies/libcarddav/debian/rules
index e898aa6d2..22b8c9e32 100755
--- a/ubuntu/_base/dependencies/libcarddav/debian/rules
+++ b/ubuntu/_base/dependencies/libcarddav/debian/rules
@@ -4,6 +4,14 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
+DEB_TIME64_API = $(shell echo | cc $(dpkg-buildflags --get CPPFLAGS) -dM -E -x c++ - | grep -q "_TIME_BITS 64" && echo true || false)
+ifeq ($(DEB_TIME64_API),true)
+DEB_TIME64_SUFFIX = 0t64
+else
+DEB_TIME64_SUFFIX =
+endif
+
+
ifdef DEB_HOST_MULTIARCH
CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
@@ -18,3 +26,39 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
-DWITH_ALL_OPTIONS="ON" \
-DBUILD_ALL="ON"
+
+post-patches::
+ dh_testdir
+ifeq ($(DEB_TIME64_API),true)
+ # update library package name for TIME64 ABI
+ ls -d debian/* | \
+ grep -E "/libcarddav\." | \
+ grep -v "\.t64$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.t64 ] || \
+ (cp -a $$a debian/libcarddav$(DEB_TIME64_SUFFIX).$${a##*.} && mv $$a $$a.t64); \
+ done
+ [ -f debian/control.t64 ] || \
+ sed -i.t64 \
+ -e "s/^Package: \\(libcarddav\\)$$/Package: \\1$(DEB_TIME64_SUFFIX)\\nReplaces: \\1\\nBreaks: \\1/" \
+ -e "s/\\(libcarddav\\) (=/\\1$(DEB_TIME64_SUFFIX) (=/" \
+ debian/control
+endif
+
+clean::
+ dh_testdir
+ dh_clean
+
+ifeq ($(DEB_TIME64_API),true)
+ # revert library package name for TIME64 ABI
+ ls -d debian/* | \
+ grep -E "\.t64$$" | \
+ while read a; do \
+ mv $$a $${a%.t64}; \
+ done
+ ls -d debian/* | \
+ grep -E "/libcarddav$(DEB_TIME64_SUFFIX)\." | \
+ xargs -r rm
+ [ ! -f debian/control.t64 ] || \
+ mv debian/control.t64 debian/control
+endif