summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/sip4-tqt/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/sip4-tqt/debian/control')
-rw-r--r--ubuntu/_base/dependencies/sip4-tqt/debian/control72
1 files changed, 19 insertions, 53 deletions
diff --git a/ubuntu/_base/dependencies/sip4-tqt/debian/control b/ubuntu/_base/dependencies/sip4-tqt/debian/control
index ca64055dd..2c7df285c 100644
--- a/ubuntu/_base/dependencies/sip4-tqt/debian/control
+++ b/ubuntu/_base/dependencies/sip4-tqt/debian/control
@@ -4,49 +4,27 @@ Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Bernd Zeimetz <bzed@debian.org>, Michael Casadevall <mcasadevall@debian.org>
-Build-Depends: debhelper (>= 9~), python-all-dev (>= 2.3.5-10), python-all-dbg, python3-all-dev, python3-all-dbg, python-support (>= 0.7.1) | dh-python, libtqtinterface-dev, bison, flex
+Build-Depends: debhelper (>= 10~), python3-all-dev, python3-all-dbg, dh-python, libtqtinterface-dev, bison, flex
Standards-Version: 3.8.4
XS-Python-Version: all
X-Python3-Version: >= 3.0
-Package: python-sip-tqt
+Package: python3-sip-tqt
Architecture: any
Section: python
-Replaces: python-sip-tqt (<< 4:14.0.0~)
-Breaks: python-sip-tqt (<< 4:14.0.0~)
-Provides: ${python:Provides}
-Depends: ${python:Depends}, ${shlibs:Depends}, ${misc:Depends}
-Conflicts: python-sip4 (<< 4.10)
-Description: Python/C++ bindings generator runtime library
- SIP-TQt is a tool for generating bindings for C++ classes with some ideas
- borrowed from SWIG, but capable of tighter bindings because of its
- specificity towards C++ and Python.
-
-Package: python-sip-tqt-dbg
-Priority: extra
-Architecture: any
-Replaces: python-sip-tqt-dbg (<< 4:14.0.0~)
-Breaks: python-sip-tqt-dbg (<< 4:14.0.0~)
-Section: debug
-Provides: ${python:Provides}
-Depends: python-sip-tqt (= ${binary:Version}), python-all-dbg, ${shlibs:Depends}, ${misc:Depends}
-Conflicts: python-sip4-dbg (<< 4.10)
-Description: Python/C++ bindings generator runtime library (debug extension)
+Provides: ${python3:Provides}
+Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Description: Python 3/C++ bindings generator runtime library
SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
.
- This package contains the extension built for the Python debug interpreter.
+ This package provides the SIP-TQt module for Python 3
-Package: python-sip-tqt-dev
+Package: python3-sip-tqt-dev
Architecture: any
Section: python
-Replaces: python-sip-tqt-dev (<< 4:14.0.0~)
-Breaks: python-sip-tqt-dev (<< 4:14.0.0~)
-Depends: ${python:Depends}, python-sip-tqt (= ${binary:Version}), python-all-dev, ${shlibs:Depends}, libjs-jquery, ${misc:Depends}
-Recommends: python-sip-tqt (>= ${source:Version})
-Provides: python-sip-dev, python-sip4-dev, sip4
-Conflicts: python-sip-dev, python-sip4-dev (<< 4.10), sip4 (<< 4.10)
+Depends: ${python3:Depends}, python3-sip-tqt (= ${binary:Version}), sip-tqt-dev, python3-all-dev, ${shlibs:Depends}, libjs-jquery, ${misc:Depends}
Description: Python/C++ bindings generator development files
SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
@@ -67,25 +45,26 @@ Description: Python/C++ bindings generator development files
- static member functions.
.
This package contains the code generator tool and the development headers
- needed to develop Python bindings with sip-tqt.
+ needed to develop Python 3 bindings with sip-tqt.
-Package: python3-sip-tqt
+Package: python3-sip-tqt-dbg
Architecture: any
-Section: python
-Provides: ${python3:Provides}
-Depends: ${python3:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Section: debug
+Priority: extra
+Depends: python3-sip-tqt (= ${binary:Version}), python3-all-dbg, ${shlibs:Depends}, ${misc:Depends}
Description: Python 3/C++ bindings generator runtime library
SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
specificity towards C++ and Python.
.
- This package provides SIP-TQt with support for Python 3
+ This package provides the SIP-TQt module for the debug build of the Python 3.
-Package: python3-sip-tqt-dev
+Package: sip-tqt-dev
Architecture: any
Section: python
-Depends: ${python:Depends}, python3-sip-tqt (= ${binary:Version}), python-all-dev, ${shlibs:Depends}, libjs-jquery, ${misc:Depends}
-Recommends: python3-sip-tqt (>= ${source:Version})
+Depends: ${python3:Depends}, ${shlibs:Depends}
+Breaks: python-sip-tqt-dev (<< 4:14.1.0~)
+Recommends: python3-sip-tqt-dev
Description: Python/C++ bindings generator development files
SIP-TQt is a tool for generating bindings for C++ classes with some ideas
borrowed from SWIG, but capable of tighter bindings because of its
@@ -105,17 +84,4 @@ Description: Python/C++ bindings generator development files
- global class instances
- static member functions.
.
- This package contains the code generator tool and the development headers
- needed to develop Python 3 bindings with sip-tqt.
-
-Package: python3-sip-tqt-dbg
-Architecture: any
-Section: debug
-Priority: extra
-Depends: python3-sip-tqt (= ${binary:Version}), python3-all-dbg, ${shlibs:Depends}, ${misc:Depends}
-Description: Python 3/C++ bindings generator runtime library
- SIP-TQt is a tool for generating bindings for C++ classes with some ideas
- borrowed from SWIG, but capable of tighter bindings because of its
- specificity towards C++ and Python.
- .
- This package contains debugging symbols for python3-sip-tqt
+ This package contains the code generator tool needed to develop Python 3 bindings with sip-tqt.