summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqca/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/dependencies/tqca/debian')
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/cdbs/debian-tde.mk30
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/changelog6
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/compat2
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/control24
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/libtqca.docs1
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/patches/series0
-rwxr-xr-xubuntu/_base/dependencies/tqca/debian/rules5
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/tqca-tls.docs1
-rw-r--r--ubuntu/_base/dependencies/tqca/debian/tqca-tls.install1
9 files changed, 60 insertions, 10 deletions
diff --git a/ubuntu/_base/dependencies/tqca/debian/cdbs/debian-tde.mk b/ubuntu/_base/dependencies/tqca/debian/cdbs/debian-tde.mk
index 24191b2cd..aba508624 100644
--- a/ubuntu/_base/dependencies/tqca/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/dependencies/tqca/debian/cdbs/debian-tde.mk
@@ -57,6 +57,15 @@ ifndef _cdbs_class_cmake
include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
endif
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
ifndef _cdbs_rules_patchsys_quilt
DEB_PATCHDIRS := debian/patches/common debian/patches
endif
@@ -73,7 +82,17 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
@@ -117,7 +136,7 @@ endif
echo "# TDE package information" >.tdepkginfo
dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
post-patches:: .tdepkginfo
@@ -183,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
@@ -204,7 +228,7 @@ debian/stamp-kde-apidox:
common-install-indep:: common-install-kde-apidox
common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
cleanbuilddir::
-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
diff --git a/ubuntu/_base/dependencies/tqca/debian/changelog b/ubuntu/_base/dependencies/tqca/debian/changelog
index 728ba7754..b560f163e 100644
--- a/ubuntu/_base/dependencies/tqca/debian/changelog
+++ b/ubuntu/_base/dependencies/tqca/debian/changelog
@@ -1,3 +1,9 @@
+tqca (4:14.1.0~s39-0debian10.0.0+0) buster; urgency=low
+
+ * Merge libtqca and tqca-tls into one source package.
+
+ -- Slávek Banko <slavek.banko@axis.cz> Thu, 20 May 2021 01:20:50 +0200
+
libtqca (4:14.1.0~s3-0debian10.0.0+0) buster; urgency=low
* Initial git build
diff --git a/ubuntu/_base/dependencies/tqca/debian/compat b/ubuntu/_base/dependencies/tqca/debian/compat
index ec635144f..f599e28b8 100644
--- a/ubuntu/_base/dependencies/tqca/debian/compat
+++ b/ubuntu/_base/dependencies/tqca/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/ubuntu/_base/dependencies/tqca/debian/control b/ubuntu/_base/dependencies/tqca/debian/control
index dd4518d0e..91abded59 100644
--- a/ubuntu/_base/dependencies/tqca/debian/control
+++ b/ubuntu/_base/dependencies/tqca/debian/control
@@ -1,8 +1,8 @@
-Source: libtqca
+Source: tqca
Section: libs
Priority: optional
-Maintainer: TDE Team <team@trinitydesktop.org>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake, libtqtinterface-dev
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, libtqtinterface-dev, libssl-dev
Standards-Version: 3.8.3
Package: libtqca
@@ -23,3 +23,21 @@ Description:
.
This is the development package containing header files and link
libraries for libtqca.
+
+Package: tqca-tls
+Section: libs
+Architecture: any
+Multi-Arch: same
+Replaces: tqca-tls (<< 4:14.0.0~)
+Breaks: tqca-tls (<< 4:14.0.0~)
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: TLS plugin for the TQt Cryptographic Architecture (TQCA)
+ This is a plugin to provide SSL/TLS capability to programs that
+ utilize the TQt Cryptographic Architecture (TQCA).
+ .
+ TQCA is a library providing an easy API for several cryptographic algorithms
+ to TQt programs.
+ .
+ At the moment only the tqca-tls plugin is packaged for debian, as it's
+ used by the package 'psi'. The generic library and several other plugins
+ will be packaged when upstream releases them.
diff --git a/ubuntu/_base/dependencies/tqca/debian/libtqca.docs b/ubuntu/_base/dependencies/tqca/debian/libtqca.docs
new file mode 100644
index 000000000..e845566c0
--- /dev/null
+++ b/ubuntu/_base/dependencies/tqca/debian/libtqca.docs
@@ -0,0 +1 @@
+README
diff --git a/ubuntu/_base/dependencies/tqca/debian/patches/series b/ubuntu/_base/dependencies/tqca/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/ubuntu/_base/dependencies/tqca/debian/patches/series
diff --git a/ubuntu/_base/dependencies/tqca/debian/rules b/ubuntu/_base/dependencies/tqca/debian/rules
index 5d7f84feb..bcf875516 100755
--- a/ubuntu/_base/dependencies/tqca/debian/rules
+++ b/ubuntu/_base/dependencies/tqca/debian/rules
@@ -4,9 +4,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
ifdef DEB_HOST_MULTIARCH
CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
@@ -14,8 +11,10 @@ else
endif
DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
+ -DBUILD_ALL="ON" \
-DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/dependencies/tqca/debian/tqca-tls.docs b/ubuntu/_base/dependencies/tqca/debian/tqca-tls.docs
new file mode 100644
index 000000000..e845566c0
--- /dev/null
+++ b/ubuntu/_base/dependencies/tqca/debian/tqca-tls.docs
@@ -0,0 +1 @@
+README
diff --git a/ubuntu/_base/dependencies/tqca/debian/tqca-tls.install b/ubuntu/_base/dependencies/tqca/debian/tqca-tls.install
new file mode 100644
index 000000000..02d23f437
--- /dev/null
+++ b/ubuntu/_base/dependencies/tqca/debian/tqca-tls.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/tqt3/plugins