summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/tdeadmin/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/_base/tdeadmin/debian/rules')
-rwxr-xr-xubuntu/_base/tdeadmin/debian/rules33
1 files changed, 0 insertions, 33 deletions
diff --git a/ubuntu/_base/tdeadmin/debian/rules b/ubuntu/_base/tdeadmin/debian/rules
deleted file mode 100755
index 8061a591c..000000000
--- a/ubuntu/_base/tdeadmin/debian/rules
+++ /dev/null
@@ -1,33 +0,0 @@
-#! /usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_DH_STRIP_ARGS := --dbg-package=tdeadmin-trinity-dbg
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-DEB_CONFIGURE_EXTRA_FLAGS := \
- --without-rpm --with-pam=tde --with-shadow --with-nis \
- --with-private-groups --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON" \
- -DKU_USERPRIVATEGROUP="true"