summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/piklab/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/maverick/applications/piklab/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/piklab/debian/rules115
1 files changed, 10 insertions, 105 deletions
diff --git a/ubuntu/maverick/applications/piklab/debian/rules b/ubuntu/maverick/applications/piklab/debian/rules
index 24ae1e8b4..f16888762 100755
--- a/ubuntu/maverick/applications/piklab/debian/rules
+++ b/ubuntu/maverick/applications/piklab/debian/rules
@@ -1,9 +1,14 @@
#!/usr/bin/make -f
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# Currently is not possible to build piklab with --enable-final
+DEB_BUILD_OPTIONS += noopt
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
@@ -13,105 +18,5 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-post-patches::
- dh_testdir
-
-config: post-patches config-stamp
-config-stamp:
- dh_testdir
-
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub admin/config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess admin/config.guess
-endif
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- ./configure CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs -Wl,--as-needed" \
- --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib \
- --with-extra-includes=/opt/trinity/include/tde \
- --mandir=/opt/trinity/share/man --infodir=/opt/trinity/share/info --enable-rpath
- touch $@
-
-build: build-stamp
-build-stamp: config-stamp
- dh_testdir
- $(MAKE)
- #docbook-to-man debian/piklab.sgml > piklab.1
- touch $@
-
-clean::
- dh_testdir
- dh_testroot
-
- rm -f config-stamp build-stamp
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f po/*.gmo
- rm -f src/common/global/svn_revision/svn_revision.h
- rm -f config.sub config.guess config.status config.log
- dh_clean
-
-install: build-stamp
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/piklab-trinity install
- chrpath --delete debian/piklab-trinity/opt/trinity/bin/*
- mv debian/piklab-trinity/opt/trinity/share/man/man1/piklab.1x debian/piklab-trinity/opt/trinity/share/man/man1/piklab.1
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs Changelog
- dh_installdocs
- dh_installexamples
- dh_install
- dh_installmenu
- dh_installman
- dh_desktop
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps -l/opt/trinity/lib
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-binary: binary-indep binary-arch
-.PHONY: config build clean binary-indep binary-arch binary install
+binary-install/piklab-trinity::
+ mv debian/$(cdbs_curpkg)/opt/trinity/share/man/man1/piklab.1x debian/$(cdbs_curpkg)/opt/trinity/share/man/man1/piklab.1