summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/krename/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/krename/debian')
-rw-r--r--ubuntu/precise/applications/krename/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/precise/applications/krename/debian/cdbs/debian-qt-kde.mk111
-rw-r--r--ubuntu/precise/applications/krename/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/precise/applications/krename/debian/cdbs/team-members16
-rw-r--r--ubuntu/precise/applications/krename/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/precise/applications/krename/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/precise/applications/krename/debian/changelog129
-rw-r--r--ubuntu/precise/applications/krename/debian/compat1
-rw-r--r--ubuntu/precise/applications/krename/debian/control20
-rw-r--r--ubuntu/precise/applications/krename/debian/copyright34
-rw-r--r--ubuntu/precise/applications/krename/debian/docs2
-rw-r--r--ubuntu/precise/applications/krename/debian/krename.187
-rw-r--r--ubuntu/precise/applications/krename/debian/krename.manpages1
-rw-r--r--ubuntu/precise/applications/krename/debian/patches/series0
-rwxr-xr-xubuntu/precise/applications/krename/debian/rules40
-rw-r--r--ubuntu/precise/applications/krename/debian/source/format1
-rw-r--r--ubuntu/precise/applications/krename/debian/source/options6
-rw-r--r--ubuntu/precise/applications/krename/debian/watch6
18 files changed, 0 insertions, 685 deletions
diff --git a/ubuntu/precise/applications/krename/debian/cdbs/buildvars.mk b/ubuntu/precise/applications/krename/debian/cdbs/buildvars.mk
deleted file mode 100644
index 23d4709dc..000000000
--- a/ubuntu/precise/applications/krename/debian/cdbs/buildvars.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2002,2003 Colin Walters <walters@debian.org>
-# Description: Defines some useful variables, but no rules
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_rules_buildvars
-_cdbs_rules_buildvars = 1
-
-CDBS_VERSION = something
-
-# Common useful variables
-DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
-
-# Split into arch/indep packages
-ifneq ($(DEB_INDEP_PACKAGES),cdbs)
-DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
-DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
-endif
-# Split into normal and udeb packages
-ifeq ($(DEB_UDEB_PACKAGES),)
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-else
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-endif
-# Too much bother for now. If someone complains we'll fix it.
-#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
-#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
-# A handy list of every package, udeb or not
-DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
-DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
-DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
-
-DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-
-# Some support for srcdir != builddir builds.
-# These are relative to the root of the package
-DEB_SRCDIR ?= .
-DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
-
-# Miscellaneous bits
-DEB_ARCH = $(shell dpkg --print-architecture)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
-DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-
-ifeq ($(words $(DEB_ALL_PACKAGES)),1)
- DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
-else
- DEB_DESTDIR = $(CURDIR)/debian/tmp/
-endif
-
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
-
-endif
diff --git a/ubuntu/precise/applications/krename/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/applications/krename/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index c807eed8c..000000000
--- a/ubuntu/precise/applications/krename/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,111 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/precise/applications/krename/debian/cdbs/kde.mk b/ubuntu/precise/applications/krename/debian/cdbs/kde.mk
deleted file mode 100644
index 765560c89..000000000
--- a/ubuntu/precise/applications/krename/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,97 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-prehook-impl::
- mkdir -p po
- -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
- -for file in po/*pot; do \
- sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
- done
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
- rm -rf po/*.pot
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/precise/applications/krename/debian/cdbs/team-members b/ubuntu/precise/applications/krename/debian/cdbs/team-members
deleted file mode 100644
index 05761af6e..000000000
--- a/ubuntu/precise/applications/krename/debian/cdbs/team-members
+++ /dev/null
@@ -1,16 +0,0 @@
-Sune Vuorela <debian@pusling.com>
-Ana Beatriz Guerrero Lopez <ana@debian.org>
-Fathi Boudra <fboudra@free.fr>
-Modestas Vainius <geromanas@mailas.com>
-Josh Metzler <joshdeb@metzlers.org>
-Isaac Clerencia <isaac@debian.org>
-Adeodato Simó <dato@net.com.org.es>
-Adeodato Simo <dato@net.com.org.es>
-Christopher Martin <chrsmrtn@debian.org>
-Daniel Schepler <schepler@debian.org>
-Sarah Hobbs <hobbsee@ubuntu.com>
-Nacho Barrientos Arias <nacho@debian.org>
-Ricardo Javier Cardenes Medina <rcardenes@debian.org>
-Ricardo Cardenes <rcardenes@debian.org>
-Armin Berres <trigger+debian@space-based.de>
-Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/precise/applications/krename/debian/cdbs/uploaders.mk b/ubuntu/precise/applications/krename/debian/cdbs/uploaders.mk
deleted file mode 100644
index 31adfe31e..000000000
--- a/ubuntu/precise/applications/krename/debian/cdbs/uploaders.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-
-MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
-
-
-debian/control.tmp:
- @if [ ! -e debian/control.in ] ; then \
- echo "this package is not yet prepared for using automatic update of uploaders"; \
- echo "Please do so."; \
- exit 1; \
- fi
- @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
-
-check-uploaders: debian/control.tmp
- @if ! diff -q debian/control debian/control.tmp ; then \
- echo "WARNING:: Control file differs from manually generated one" ; \
- echo "WARNING:: Please update it manually and check it afterwards" ; \
- echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
- echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
- fi
-
-
-clean::
- rm -f debian/control.tmp
-
-update-uploaders: debian/control.tmp
- @mv -f debian/control.tmp debian/control
-
-makebuilddir:: check-uploaders
diff --git a/ubuntu/precise/applications/krename/debian/cdbs/versions.pl b/ubuntu/precise/applications/krename/debian/cdbs/versions.pl
deleted file mode 100644
index 75c9add4b..000000000
--- a/ubuntu/precise/applications/krename/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "KDE-Version3=$version3\n";
-print "KDE-Version2=$version2\n";
-print "KDE-Next-Version3=$version3_next\n";
-print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/precise/applications/krename/debian/changelog b/ubuntu/precise/applications/krename/debian/changelog
deleted file mode 100644
index fb28d1f29..000000000
--- a/ubuntu/precise/applications/krename/debian/changelog
+++ /dev/null
@@ -1,129 +0,0 @@
-krename-trinity (3.0.14~1ubuntu0) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
-
-krename-trinity (3.0.14~0ubuntu6) intrepid; urgency=low
-
- * Moved Trinity to /opt/trinity
- * Integrated properly with KDE4.2+
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 05 March 2009 29:52:00 -0600
-
-krename-trinity (3.0.14~0ubuntu5) intrepid; urgency=low
-
- * Added -trinity suffix
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Fri, 12 Dec 2008 14:34:00 -0600
-
-krename (3.0.14-1) unstable; urgency=low
-
- * New Upstream Release (Closes: #402859, #423440)
- * Adopted Package - New Maintainer & Uploaders
- * debian/control:
- - Maintainer set to Debian KDE Extras Team
- - Richard A. Johnson set to uploaders
- - updated standards to version 3.7.2 - no changes necessary
- - updated build-dep debhelper >= 5 (changes to compat)
- - added libtool and automake1.10 to build-dep for Relibtoolization
- - added Krenames URL to description
- * debian/rules:
- - cleaned out commented lines
- - Relibtoolization at build time
- * Updated debian/copyright
-
- -- Richard A. Johnson <nixternal@ubuntu.com> Fri, 18 May 2007 21:54:22 -0500
-
-krename (3.0.9-2.1) unstable; urgency=low
-
- * NMU.
- * Remove build dependency on g++-3.4. Closes: #385835.
-
- -- Matthias Klose <doko@debian.org> Sun, 3 Sep 2006 13:41:32 +0000
-
-krename (3.0.9-2) unstable; urgency=low
-
- * No more Build-Depend on xlibs-dev
-
- -- Roman Kreisel <roman.kreisel@web.de> Wed, 30 Nov 2005 13:46:48 +0100
-
-krename (3.0.9-1) unstable; urgency=low
-
- * New upstream release
-
- -- Roman Kreisel <roman.kreisel@web.de> Fri, 28 Oct 2005 21:56:34 +0200
-
-krename (3.0.8-1) unstable; urgency=low
-
- * New upstream release (Closes: #329969)
-
- -- Roman Kreisel <roman.kreisel@web.de> Sat, 24 Sep 2005 19:22:44 +0200
-
-krename (3.0.7-4) unstable; urgency=low
-
- * Use GCC 3.4 on arm, m68k and hppa
- * updated manpage
- * Build-Dependency on xlibs-dev
- * moved from "utils - optional" to "kde - optional"
-
- -- Roman Kreisel <roman.kreisel@web.de> Tue, 6 Sep 2005 01:30:57 +0200
-
-krename (3.0.7-3) unstable; urgency=low
-
- * moved from dpatch to simple-patchsys of cdbs
- * Corrected a typo in copyright-file (wrong telephone-no. of fsf)
- * No more "0 errors occurred"-Message on successful operation. Fixed by
- upstream. (Closes: #309253)
-
- -- Roman Kreisel <roman.kreisel@web.de> Fri, 2 Sep 2005 16:15:32 +0200
-
-krename (3.0.7-2) unstable; urgency=low
-
- * Updated/corrected german translation (Closes: #313984)
-
- -- Roman Kreisel <roman.kreisel@web.de> Fri, 2 Sep 2005 14:59:04 +0200
-
-krename (3.0.7-1) unstable; urgency=low
-
- * New upstream release
-
- -- Roman Kreisel <roman.kreisel@web.de> Mon, 29 Aug 2005 16:13:56 +0200
-
-krename (3.0.6-1) unstable; urgency=low
-
- * New upstream release
-
- -- Roman Kreisel <roman.kreisel@web.de> Thu, 18 Aug 2005 15:34:07 +0200
-
-krename (3.0.4-1) unstable; urgency=low
-
- * New upstream release
-
- -- Roman Kreisel <roman.kreisel@web.de> Thu, 21 Apr 2005 18:00:14 +0200
-
-krename (3.0.3-2) unstable; urgency=low
-
- * Initial Debian release (Closes: #286278, #279143)
-
- -- Roman Kreisel <roman.kreisel@web.de> Mon, 14 Feb 2005 20:38:59 +0100
-
-krename (3.0.3-1) unstable; urgency=low
-
- * New upstream release
- * Fixed Build-Depends
-
- -- Roman Kreisel <roman.kreisel@web.de> Mon, 14 Feb 2005 20:27:10 +0100
-
-krename (3.0.2-2) staging; urgency=low
-
- * Added debian/watch for easier updating
-
- -- Roman Kreisel <roman.kreisel@web.de> Sat, 15 Jan 2005 18:46:03 +0100
-
-krename (3.0.2-1) staging; urgency=low
-
- * Initial Release.
-
- -- Roman Kreisel <roman.kreisel@web.de> Sun, 14 Nov 2004 23:23:38 +0100
-
diff --git a/ubuntu/precise/applications/krename/debian/compat b/ubuntu/precise/applications/krename/debian/compat
deleted file mode 100644
index 7ed6ff82d..000000000
--- a/ubuntu/precise/applications/krename/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/ubuntu/precise/applications/krename/debian/control b/ubuntu/precise/applications/krename/debian/control
deleted file mode 100644
index 2aa88df30..000000000
--- a/ubuntu/precise/applications/krename/debian/control
+++ /dev/null
@@ -1,20 +0,0 @@
-Source: krename-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Uploaders: Richard A. Johnson <nixternal@ubuntu.com>
-Build-Depends: debhelper (>= 5), quilt, cdbs, tdelibs14-trinity-dev, patchutils, libx11-dev, libxext-dev, libxpm-dev, x-dev | x11proto-core-dev | libx11-dev, perl, automake, autoconf, libtool, libltdl-dev
-Standards-Version: 3.8.4
-
-Package: krename-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: krename-kde3 (<< 4:14.0.0~), krename-trinity (<< 4:14.0.0~)
-Breaks: krename-kde3 (<< 4:14.0.0~), krename-trinity (<< 4:14.0.0~)
-Description: Powerful batch renamer for KDE 3.x [Trinity]
- This package contains a very powerful batch file renamer for Trinity
- which can rename a list of files based on a set of expressions.
- It can copy/move the files to another directory or simply rename
- the input files.
- .
- Homepage: http://www.krename.net
diff --git a/ubuntu/precise/applications/krename/debian/copyright b/ubuntu/precise/applications/krename/debian/copyright
deleted file mode 100644
index e90f32cab..000000000
--- a/ubuntu/precise/applications/krename/debian/copyright
+++ /dev/null
@@ -1,34 +0,0 @@
-This package was debianized by Roman Kreisel <roman.kreisel@web.de> on
-Sun, 14 Nov 2004 23:23:38 +0100.
-
-Maintenance was taken over by the Debian KDE Extras Team on Thu, 17 May 2007
-15:01:00 -0600
-
-It was downloaded from http://www.krename.net/
-
-Copyright: 2001-2007 Dominik Seichter <domseichter@web.de>
-
-Upstream Author: Dominik Seichter
-
-License:
-
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; version 2 dated June, 1991.
-
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this package; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
- 02110-1301, USA.
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
-The Debian packaging is
-(C) 2007 Richard A. Johnson <nixternal@ubuntu.com>
-and is licensed under the GPL, see above.
diff --git a/ubuntu/precise/applications/krename/debian/docs b/ubuntu/precise/applications/krename/debian/docs
deleted file mode 100644
index 724e08449..000000000
--- a/ubuntu/precise/applications/krename/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-README
-TODO
diff --git a/ubuntu/precise/applications/krename/debian/krename.1 b/ubuntu/precise/applications/krename/debian/krename.1
deleted file mode 100644
index 153c74797..000000000
--- a/ubuntu/precise/applications/krename/debian/krename.1
+++ /dev/null
@@ -1,87 +0,0 @@
-.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.35.
-.TH QT: "1" "September 2005" "Qt: 3.3.5" "User Commands"
-.SH NAME
-Qt: \- manual page for Qt: 3.3.5
-.SH SYNOPSIS
-.B krename
-[\fIQt-options\fR] [\fIKDE-options\fR] [\fIfile\fR]
-.SH DESCRIPTION
-KRename is a batch file renamer which can rename a
-list of files based on a set of expressions.
-.PP
-If you like KRename you may want to support it.
-Testing, bug fixes and feature request are as welcome
-as financial support (everybody needs money ;)
-See help files for details.
-.SS "Generic options:"
-.TP
-\fB\-\-help\fR
-Show help about options
-.TP
-\fB\-\-help\-qt\fR
-Show Qt specific options
-.TP
-\fB\-\-help\-kde\fR
-Show KDE specific options
-.TP
-\fB\-\-help\-all\fR
-Show all options
-.TP
-\fB\-\-author\fR
-Show author information
-.TP
-\fB\-v\fR, \fB\-\-version\fR
-Show version information
-.TP
-\fB\-\-license\fR
-Show license information
-.TP
-\fB\-\-\fR
-End of options
-.SS "Arguments:"
-.TP
-file
-file will be added to the list of files for renaming
-.SH OPTIONS
-.TP
-\fB\-r\fR +[dir]
-add directory recursively
-.TP
-\fB\-\-template\fR +
-set a template
-.TP
-\fB\-\-extension\fR +
-set a template for the file extension
-.TP
-\fB\-\-use\-plugin\fR +
-enable a plugin for use
-.TP
-\fB\-\-copy\fR +[dir]
-copy files to directory
-.TP
-\fB\-\-move\fR +[dir]
-move files to directory
-.TP
-\fB\-\-profile\fR +[profile]
-load the profile named [profile] on startup
-.TP
-\fB\-\-start\fR
-start renaming immediately
-.TP
-\fB\-\-nopreview\fR
-create no realtime preview
-.PP
-KDE: 3.4.2
-KRename: 3.0.8
-.SH "SEE ALSO"
-The full documentation for
-.B Qt:
-is maintained as a Texinfo manual. If the
-.B info
-and
-.B Qt:
-programs are properly installed at your site, the command
-.IP
-.B info Qt:
-.PP
-should give you access to the complete manual.
diff --git a/ubuntu/precise/applications/krename/debian/krename.manpages b/ubuntu/precise/applications/krename/debian/krename.manpages
deleted file mode 100644
index ded8f6473..000000000
--- a/ubuntu/precise/applications/krename/debian/krename.manpages
+++ /dev/null
@@ -1 +0,0 @@
-debian/krename.1
diff --git a/ubuntu/precise/applications/krename/debian/patches/series b/ubuntu/precise/applications/krename/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
--- a/ubuntu/precise/applications/krename/debian/patches/series
+++ /dev/null
diff --git a/ubuntu/precise/applications/krename/debian/rules b/ubuntu/precise/applications/krename/debian/rules
deleted file mode 100755
index e334635a3..000000000
--- a/ubuntu/precise/applications/krename/debian/rules
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/make -f
-
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-### Libtool and Automake updates
-post-patches:: debian/stamp-autothings-update
-debian/stamp-autothings-update:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- for f in /usr/share/automake-1.10/*; do \
- if test -f $$f && \
- test -f $(DEB_SRCDIR)/admin/`basename $$f`; then \
- cp -f $$f $(DEB_SRCDIR)/admin; \
- fi; \
- done
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- touch $@
diff --git a/ubuntu/precise/applications/krename/debian/source/format b/ubuntu/precise/applications/krename/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/precise/applications/krename/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/precise/applications/krename/debian/source/options b/ubuntu/precise/applications/krename/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/precise/applications/krename/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*
diff --git a/ubuntu/precise/applications/krename/debian/watch b/ubuntu/precise/applications/krename/debian/watch
deleted file mode 100644
index 47a31479a..000000000
--- a/ubuntu/precise/applications/krename/debian/watch
+++ /dev/null
@@ -1,6 +0,0 @@
-# Example watch control file for uscan
-# Rename this file to "watch" and then you can run the "uscan" command
-# to check for upstream updates and more.
-# Site Directory Pattern Version Script
-version=2
-http://heanet.dl.sourceforge.net/sourceforge/krename/krename-(.*)\.tar\.bz2 debian uupdate