summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/kshutdown/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/kshutdown/debian')
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/cdbs/debian-qt-kde.mk111
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/changelog98
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/compat1
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/control20
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/copyright13
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/dirs2
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/docs4
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/kshutdown.1115
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/manpages1
-rwxr-xr-xubuntu/precise/applications/kshutdown/debian/rules37
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/source/format1
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/source/options6
-rw-r--r--ubuntu/precise/applications/kshutdown/debian/watch11
17 files changed, 0 insertions, 651 deletions
diff --git a/ubuntu/precise/applications/kshutdown/debian/cdbs/buildvars.mk b/ubuntu/precise/applications/kshutdown/debian/cdbs/buildvars.mk
deleted file mode 100644
index 23d4709dc..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/cdbs/buildvars.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2002,2003 Colin Walters <walters@debian.org>
-# Description: Defines some useful variables, but no rules
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_rules_buildvars
-_cdbs_rules_buildvars = 1
-
-CDBS_VERSION = something
-
-# Common useful variables
-DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
-
-# Split into arch/indep packages
-ifneq ($(DEB_INDEP_PACKAGES),cdbs)
-DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
-DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
-endif
-# Split into normal and udeb packages
-ifeq ($(DEB_UDEB_PACKAGES),)
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-else
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-endif
-# Too much bother for now. If someone complains we'll fix it.
-#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
-#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
-# A handy list of every package, udeb or not
-DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
-DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
-DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
-
-DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-
-# Some support for srcdir != builddir builds.
-# These are relative to the root of the package
-DEB_SRCDIR ?= .
-DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
-
-# Miscellaneous bits
-DEB_ARCH = $(shell dpkg --print-architecture)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
-DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-
-ifeq ($(words $(DEB_ALL_PACKAGES)),1)
- DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
-else
- DEB_DESTDIR = $(CURDIR)/debian/tmp/
-endif
-
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
-
-endif
diff --git a/ubuntu/precise/applications/kshutdown/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/applications/kshutdown/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index f72df2152..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,111 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-#include debian/cdbs/uploaders.mk
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/precise/applications/kshutdown/debian/cdbs/kde.mk b/ubuntu/precise/applications/kshutdown/debian/cdbs/kde.mk
deleted file mode 100644
index 765560c89..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,97 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-prehook-impl::
- mkdir -p po
- -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
- -for file in po/*pot; do \
- sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
- done
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
- rm -rf po/*.pot
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/precise/applications/kshutdown/debian/cdbs/uploaders.mk b/ubuntu/precise/applications/kshutdown/debian/cdbs/uploaders.mk
deleted file mode 100644
index 31adfe31e..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/cdbs/uploaders.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-
-MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
-
-
-debian/control.tmp:
- @if [ ! -e debian/control.in ] ; then \
- echo "this package is not yet prepared for using automatic update of uploaders"; \
- echo "Please do so."; \
- exit 1; \
- fi
- @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
-
-check-uploaders: debian/control.tmp
- @if ! diff -q debian/control debian/control.tmp ; then \
- echo "WARNING:: Control file differs from manually generated one" ; \
- echo "WARNING:: Please update it manually and check it afterwards" ; \
- echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
- echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
- fi
-
-
-clean::
- rm -f debian/control.tmp
-
-update-uploaders: debian/control.tmp
- @mv -f debian/control.tmp debian/control
-
-makebuilddir:: check-uploaders
diff --git a/ubuntu/precise/applications/kshutdown/debian/cdbs/versions.pl b/ubuntu/precise/applications/kshutdown/debian/cdbs/versions.pl
deleted file mode 100644
index 75c9add4b..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "KDE-Version3=$version3\n";
-print "KDE-Version2=$version2\n";
-print "KDE-Next-Version3=$version3_next\n";
-print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/precise/applications/kshutdown/debian/changelog b/ubuntu/precise/applications/kshutdown/debian/changelog
deleted file mode 100644
index 3ddab14cf..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/changelog
+++ /dev/null
@@ -1,98 +0,0 @@
-kshutdown-trinity (1.0.4-1) unstable; urgency=low
-
- * Initial Release for TDE
-
- -- Slávek Banko <slavek.banko@axis.cz> Sun, 27 Jul 2013 02:25:45 +0200
-
-kshutdown (1.0.4-1) unstable; urgency=low
-
- * New upstream release.
- * Updated standard version to 3.8.1
- * Dropped patch fixing deprecated desktop entries (fixed upstream).
- * Bumped compat level to 7.
-
- -- Romain Beauxis <toots@rastageeks.org> Fri, 27 Mar 2009 13:36:48 +0100
-
-kshutdown (1.0.3-1) unstable; urgency=low
-
- * New upstream release
- * Refreshed patch
- * Updated standard version to 3.8.0
-
- -- Romain Beauxis <toots@rastageeks.org> Fri, 20 Jun 2008 02:33:51 +0200
-
-kshutdown (1.0.2-1) unstable; urgency=low
-
- * New upstream release
- * Updated standard version to 3.7.3 (no changes)
-
- -- Romain Beauxis <toots@rastageeks.org> Tue, 11 Dec 2007 01:38:55 +0100
-
-kshutdown (1.0.1-2) unstable; urgency=low
-
- * Added linker flags to remove non-needed link dependencies.
-
- -- Romain Beauxis <toots@rastageeks.org> Wed, 21 Nov 2007 09:51:59 +0100
-
-kshutdown (1.0.1-1) unstable; urgency=low
-
- * New upstream release
- * Fixed watch file (thanks to Raphael Geissert)
- Closes: #449772
-
- -- Romain Beauxis <toots@rastageeks.org> Sun, 18 Nov 2007 14:39:07 +0100
-
-kshutdown (1.0-1) unstable; urgency=low
-
- * New upstream release.
- * Fix for FTBFS with GCC 4.3 applied upstream
- Closes: #417301
-
- -- Romain Beauxis <toots@rastageeks.org> Mon, 23 Apr 2007 13:41:01 +0200
-
-kshutdown (0.9.1~beta-1) experimental; urgency=low
-
- * First upload of the next release to experimental.
- * Updated debian standards
- * Added workaround for buggy rpath setting
- * Switched to cdbs' kde class
-
- -- Romain Beauxis <toots@rastageeks.org> Wed, 21 Feb 2007 02:10:26 +0100
-
-kshutdown (0.8.2-1) unstable; urgency=low
-
- * New upstream release
-
- -- Romain Beauxis <toots@rastageeks.org> Tue, 14 Feb 2006 03:08:46 +0100
-
-kshutdown (0.8-1) unstable; urgency=low
-
- * New upstream release
- * Added swedish translation (Closes: #337551)
-
- -- Romain Beauxis <toots@rastageeks.org> Tue, 29 Nov 2005 02:30:38 +0100
-
-kshutdown (0.6.0-4) unstable; urgency=low
-
- * Workaround for FTBFS on some arch (see gcc Bug#323133)
-
- -- Romain Beauxis <toots@rastageeks.org> Mon, 5 Sep 2005 19:54:24 +0200
-
-kshutdown (0.6.0-3) unstable; urgency=low
-
- * New upload to rebuild against new KDE and C++ libraries.
-
- -- Romain Beauxis <toots@rastageeks.org> Mon, 5 Sep 2005 11:00:11 +0200
-
-kshutdown (0.6.0-2) unstable; urgency=low
-
- * Minor Debian fixes.
-
- -- Romain Beauxis <toots@rastageeks.org> Fri, 27 May 2005 11:35:55 +0200
-
-kshutdown (0.6.0-1) unstable; urgency=low
-
- * Initial Release. (closes: #305843)
-
- -- Romain Beauxis <toots@rastageeks.org> Thu, 14 Apr 2005 02:05:09 +0200
-
diff --git a/ubuntu/precise/applications/kshutdown/debian/compat b/ubuntu/precise/applications/kshutdown/debian/compat
deleted file mode 100644
index 7f8f011eb..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/ubuntu/precise/applications/kshutdown/debian/control b/ubuntu/precise/applications/kshutdown/debian/control
deleted file mode 100644
index 720e0f415..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/control
+++ /dev/null
@@ -1,20 +0,0 @@
-Source: kshutdown-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: cdbs (>= 0.4.23-1.1), autotools-dev, debhelper (>= 7.0.1), automake, libtool, tdelibs14-trinity-dev
-Standards-Version: 3.8.1
-
-Package: kshutdown-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: an advanced shut down utility for TDE
- It has 4 main commands:
- .
- - Shut Down (logout and halt the system),
- - Reboot (logout and reboot the system),
- - Lock Screen (lock the screen using a screen saver),
- - Logout (end the session and logout the user).
- .
- It features time and delay options, command line support, wizard,
- and sounds.
diff --git a/ubuntu/precise/applications/kshutdown/debian/copyright b/ubuntu/precise/applications/kshutdown/debian/copyright
deleted file mode 100644
index dc1726a85..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/copyright
+++ /dev/null
@@ -1,13 +0,0 @@
-This package was debianized by Romain Beauxis <toots@rastageeks.org> on
-Thu, 14 Apr 2005 02:05:09 +0200.
-
-It was downloaded from http://kshutdown.sourceforge.net/download.html
-
-Copyright: 2003-2008 Konrad Twardowski <kdtonline@poczta.onet.pl>
-
-License:
-
-You are free to distribute this software under the terms of
-the GNU General Public License.
-On Debian systems, the complete text of the GNU General Public
-License can be found in the file `/usr/share/common-licenses/GPL'.
diff --git a/ubuntu/precise/applications/kshutdown/debian/dirs b/ubuntu/precise/applications/kshutdown/debian/dirs
deleted file mode 100644
index dee03de4a..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/dirs
+++ /dev/null
@@ -1,2 +0,0 @@
-opt/trinity/bin
-opt/trinity/share/apps/kconf_update
diff --git a/ubuntu/precise/applications/kshutdown/debian/docs b/ubuntu/precise/applications/kshutdown/debian/docs
deleted file mode 100644
index d40f58a45..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/docs
+++ /dev/null
@@ -1,4 +0,0 @@
-README
-AUTHORS
-TODO
-VERSION
diff --git a/ubuntu/precise/applications/kshutdown/debian/kshutdown.1 b/ubuntu/precise/applications/kshutdown/debian/kshutdown.1
deleted file mode 100644
index 46ff37717..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/kshutdown.1
+++ /dev/null
@@ -1,115 +0,0 @@
-.\" Hey, EMACS: -*- nroff -*-
-.\" First parameter, NAME, should be all caps
-.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
-.\" other parameters are allowed: see man(7), man(1)
-.TH KSHUTDOWN 1 "avril 14, 2005"
-.\" Please adjust this date whenever revising the manpage.
-.\"
-.\" Some roff macros, for reference:
-.\" .nh disable hyphenation
-.\" .hy enable hyphenation
-.\" .ad l left justify
-.\" .ad b justify to both left and right margins
-.\" .nf disable filling
-.\" .fi enable filling
-.\" .br insert line break
-.\" .sp <n> insert n+1 empty lines
-.\" for manpage-specific macros, see man(7)
-.SH NAME
-kshutdown \- A Shut Down Utility for TDE
-.SH SYNOPSIS
-.B kshutdown
-.RI [ Qt-options ]
-.RI [ TDE-options ]
-.RI [ options ]
-.RI time
-.SH DESCRIPTION
-This manual page was written for the Debian distribution
-because the original program does not have a manual page.
-.PP
-This manual page documents briefly the
-.B kshutdown
-utility.
-.PP
-.\" TeX users may be more comfortable with the \fB<whatever>\fP and
-.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
-.\" respectively.
-.SH OPTIONS
-A summary of options is included below.
-
-.TP
-Generic options:
-.TP
-.B \-\-help
-Show help about options
-.TP
-.B \-\-help\-qt
-Show Qt specific options
-.TP
-.B \-\-help\-tde
-Show TDE specific options
-.TP
-.B \-\-help\-all
-Show all options
-.TP
-.B \-\-author
-Show author information
-.TP
-.B \-v, \-\-version
-Show version information
-.TP
-.B \-\-license
-Show license information
-.TP
-.B \-\-
-End of options
-
-.TP
-Options:
-.TP
-.B \-s, \-\-shutdown
- Turn off computer
-.TP
-.B \-h, \-\-halt
-Turn off computer
-.TP
-.B \-r, \-\-reboot
-Restart computer
-.TP
-.B \-k, \-\-lock
-Lock session
-.TP
-.B \-l, \-\-logout
-End current session
-.TP
-.B \-w, \-\-wizard
-Wizard
-.TP
-.B \-\-standard
-Show standard logout dialog
-.TP
-.B \-c, \-\-cancel
-Cancel an active action
-.TP
-.B \-\-init
-Don't show window at startup
-.TP
-.B \-\-test
-Enable test mode
-.TP
-.B \-\-default
-Disable test mode
-
-.TP
-Arguments:
-.TP
-.B time
-Time; Examples: 01:30 - absolute time (HH:MM); 10 - number of minutes to wait from now
-.SH AUTHOR
-kshutdown was written by Konrad Twardowski <kdtonline@poczta.onet.pl>.
-.PP
-This manual page was written by Romain Beauxis <toots@rastageeks.org>,
-for the Debian project Permission is granted to copy, distribute and/or
-modify this document under the terms of the GNU General Public
-License, Version 2 any later version published by the Free Software Foundation.
-
diff --git a/ubuntu/precise/applications/kshutdown/debian/manpages b/ubuntu/precise/applications/kshutdown/debian/manpages
deleted file mode 100644
index f7176be3d..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/manpages
+++ /dev/null
@@ -1 +0,0 @@
-debian/kshutdown.1
diff --git a/ubuntu/precise/applications/kshutdown/debian/rules b/ubuntu/precise/applications/kshutdown/debian/rules
deleted file mode 100755
index 78ead2287..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/rules
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-binary-install/kshutdown-trinity::
- dh_testdir
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap
diff --git a/ubuntu/precise/applications/kshutdown/debian/source/format b/ubuntu/precise/applications/kshutdown/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/precise/applications/kshutdown/debian/source/options b/ubuntu/precise/applications/kshutdown/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*
diff --git a/ubuntu/precise/applications/kshutdown/debian/watch b/ubuntu/precise/applications/kshutdown/debian/watch
deleted file mode 100644
index 740658699..000000000
--- a/ubuntu/precise/applications/kshutdown/debian/watch
+++ /dev/null
@@ -1,11 +0,0 @@
-# Example watch control file for uscan
-# Rename this file to "watch" and then you can run the "uscan" command
-# to check for upstream updates and more.
-# See uscan(1) for format
-
-# Compulsory line, this is a version 3 file
-version=3
-
-# Uncomment to examine a Webserver directory
-http://sf.net/kshutdown/kshutdown-(.*(?<!beta))\.tar\.bz2
-