summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/tde-style-qtcurve/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/tde-style-qtcurve/debian')
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/debian-qt-kde.mk112
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/team-members16
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/changelog171
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/compat1
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/control31
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/control.in32
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/copyright33
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/docs2
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/patches/series0
-rwxr-xr-xubuntu/precise/applications/tde-style-qtcurve/debian/rules32
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/scan-version41
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/source/format1
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/source/options6
-rw-r--r--ubuntu/precise/applications/tde-style-qtcurve/debian/tde-style-qtcurve-trinity.install1
18 files changed, 0 insertions, 710 deletions
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/buildvars.mk b/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/buildvars.mk
deleted file mode 100644
index 23d4709dc..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/buildvars.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2002,2003 Colin Walters <walters@debian.org>
-# Description: Defines some useful variables, but no rules
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_rules_buildvars
-_cdbs_rules_buildvars = 1
-
-CDBS_VERSION = something
-
-# Common useful variables
-DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
-
-# Split into arch/indep packages
-ifneq ($(DEB_INDEP_PACKAGES),cdbs)
-DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
-DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
-endif
-# Split into normal and udeb packages
-ifeq ($(DEB_UDEB_PACKAGES),)
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-else
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-endif
-# Too much bother for now. If someone complains we'll fix it.
-#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
-#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
-# A handy list of every package, udeb or not
-DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
-DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
-DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
-
-DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-
-# Some support for srcdir != builddir builds.
-# These are relative to the root of the package
-DEB_SRCDIR ?= .
-DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
-
-# Miscellaneous bits
-DEB_ARCH = $(shell dpkg --print-architecture)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
-DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-
-ifeq ($(words $(DEB_ALL_PACKAGES)),1)
- DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
-else
- DEB_DESTDIR = $(CURDIR)/debian/tmp/
-endif
-
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
-
-endif
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index c5d8ecfd3..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,112 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
- rm -f debian/stamp-cvs-make
-
-endif
-
-#common-build-indep:: debian/stamp-kde-apidox
-#debian/stamp-kde-apidox:
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
-# touch $@
-#
-#common-install-indep:: common-install-kde-apidox
-#common-install-kde-apidox::
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-#
-#clean::
-# rm -f debian/stamp-kde-apidox
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/kde.mk b/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/kde.mk
deleted file mode 100644
index 4a098a312..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,97 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-# include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-prehook-impl::
- mkdir -p po
- -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
- -for file in po/*pot; do \
- sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
- done
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
-# $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
- rm -rf po/*.pot
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/team-members b/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/team-members
deleted file mode 100644
index 05761af6e..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/team-members
+++ /dev/null
@@ -1,16 +0,0 @@
-Sune Vuorela <debian@pusling.com>
-Ana Beatriz Guerrero Lopez <ana@debian.org>
-Fathi Boudra <fboudra@free.fr>
-Modestas Vainius <geromanas@mailas.com>
-Josh Metzler <joshdeb@metzlers.org>
-Isaac Clerencia <isaac@debian.org>
-Adeodato Simó <dato@net.com.org.es>
-Adeodato Simo <dato@net.com.org.es>
-Christopher Martin <chrsmrtn@debian.org>
-Daniel Schepler <schepler@debian.org>
-Sarah Hobbs <hobbsee@ubuntu.com>
-Nacho Barrientos Arias <nacho@debian.org>
-Ricardo Javier Cardenes Medina <rcardenes@debian.org>
-Ricardo Cardenes <rcardenes@debian.org>
-Armin Berres <trigger+debian@space-based.de>
-Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/uploaders.mk b/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/uploaders.mk
deleted file mode 100644
index 31adfe31e..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/uploaders.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-
-MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
-
-
-debian/control.tmp:
- @if [ ! -e debian/control.in ] ; then \
- echo "this package is not yet prepared for using automatic update of uploaders"; \
- echo "Please do so."; \
- exit 1; \
- fi
- @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
-
-check-uploaders: debian/control.tmp
- @if ! diff -q debian/control debian/control.tmp ; then \
- echo "WARNING:: Control file differs from manually generated one" ; \
- echo "WARNING:: Please update it manually and check it afterwards" ; \
- echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
- echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
- fi
-
-
-clean::
- rm -f debian/control.tmp
-
-update-uploaders: debian/control.tmp
- @mv -f debian/control.tmp debian/control
-
-makebuilddir:: check-uploaders
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/versions.pl b/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/versions.pl
deleted file mode 100644
index 75c9add4b..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "KDE-Version3=$version3\n";
-print "KDE-Version2=$version2\n";
-print "KDE-Next-Version3=$version3_next\n";
-print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/changelog b/ubuntu/precise/applications/tde-style-qtcurve/debian/changelog
deleted file mode 100644
index f7612d81f..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/changelog
+++ /dev/null
@@ -1,171 +0,0 @@
-tde-style-qtcurve-trinity (0.55.2-1ubuntu8) karmic; urgency=low
-
- * Now provides tde-style-qtcurve for backward compatibility
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 17 Sep 2009 16:05:00 -0600
-
-tde-style-qtcurve-trinity (0.55.2-1ubuntu7) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
-
-tde-style-qtcurve-trinity (0.55.2-1ubuntu6) intrepid; urgency=low
-
- * Moved Trinity to /opt/trinity
- * Integrated properly with KDE4.2+
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 03 March 2009 21:15:00 -0600
-
-tde-style-qtcurve-trinity (0.55.2-1ubuntu5) intrepid; urgency=low
-
- * Added -trinity suffix
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 03 Dec 2008 18:37:00 -0600
-
-tde-style-qtcurve (0.55.2-1ubuntu3) hardy; urgency=low
-
- * Set toolbar handles to sunken lines by default in
- kubuntu_01_default_settings.diff
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 31 Mar 2008 13:04:55 +0100
-
-tde-style-qtcurve (0.55.2-1ubuntu2) hardy; urgency=low
-
- * Add kubuntu_01_default_settings.diff for nicer defaults. Flat
- toolbars and don't darken menubars.
- * Build in !=srcdir so it can clean properly
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 17 Mar 2008 14:54:33 +0000
-
-tde-style-qtcurve (0.55.2-1ubuntu1) hardy; urgency=low
-
- * Merge from debian unstable, remaining changes:
- - debian/scan-version: Script to scan and download new upstream releases
- (uscan will not work with links from kde-look.org).
- - debian/copyright:
- - Replaced FSF address.
- - Removed dh_make comments.
- - debian/rules:
- - Added get-orig-source rule.
- - Use cmake to build.
- - debian/dirs:
- - Deleted, not needed (and creates empty /usr/bin).
-
- -- Stephan Hermann <sh@sourcecode.de> Mon, 21 Jan 2008 19:23:02 +0100
-
-tde-style-qtcurve (0.55.2-1) unstable; urgency=low
-
- * New upstream version (Closes: #449309)
-
- -- Bastian Venthur <venthur@debian.org> Sun, 20 Jan 2008 17:17:49 +0100
-
-tde-style-qtcurve (0.55.1-0ubuntu1) hardy; urgency=low
-
- * New upstream release. (LP: #179655)
- * debian/scan-version: Script to scan and download new upstream releases
- (uscan will not work with links from kde-look.org).
- * debian/control:
- - Build-depend on cmake.
- - Updated Standards-Version.
- * debian/copyright:
- - Replaced FSF address.
- - Removed dh_make comments.
- * debian/rules:
- - Added get-orig-source rule.
- - Use cmake to build.
- * debian/dirs:
- - Deleted, not needed (and creates empty /usr/bin).
-
- -- Matvey Kozhev <sikon@lucidfox.org> Tue, 01 Jan 2008 17:08:56 +0600
-
-tde-style-qtcurve (0.52.3-1) unstable; urgency=low
-
- * Don't lighten border of disabled check/radio buttons.
- * Lighten trough of disabled slider.
- * Modify tdehtml check to also check to see if widget name == "__tdehtml"
- * Store tdehtml widgets in a map, to speed up checking.
- * Fix shadow on comboboxes.
- * Draw background of checked menuitem icons as per KDE4.
-
- -- Bastian Venthur <venthur@debian.org> Fri, 10 Aug 2007 10:10:55 +0200
-
-tde-style-qtcurve (0.52.2-1) unstable; urgency=low
-
- New upstream version
-
- [0.52.2]
-
- * Fix crash when slider color == button.
-
- [0.52.1]
-
- * Draw emphasis around menus when not lightening.
- * Use button colors to border entry fields.
- * Don't allow scrollbars to be recolored.
- * Fix amarok menus!
-
-
- -- Bastian Venthur <venthur@debian.org> Sun, 24 Jun 2007 13:13:10 +0200
-
-tde-style-qtcurve (0.52-1) unstable; urgency=low
-
- * New upstream version
-
- * Use 'dull glass' as the default gradient - previous default is now
- called 'Clean'.
- * Darken slider mouse over colour if slider is not shaded.
- * Use thinner slider mouse over sections if slider is not shaded.
- * Improve look of small V arrows.
- * Even duller dull glass, but much more useable.
- * Fix setting of check/radio colour.
- * Only highlight editable combo arrow when mouse over arrow, not over edit
- field - more Gtk like.
- * Added one config file option (no gui):
- gtkScrollViews set to 'true' to have the scrollbars drawn outside of
- scrollviews. (However, doesn't look very good)
- * Lighten combo list frame.
- * Dont round MDI buttons.
- * Fix opera's MDI buttons within menubars.
- * Always assume PE_ButtonBevel is enabled - used for QtConfig's colour
- buttons
-
- -- Bastian Venthur <venthur@debian.org> Tue, 19 Jun 2007 17:35:33 +0200
-
-tde-style-qtcurve (0.51-2) unstable; urgency=low
-
- * Changed priority from extra to optional
-
- -- Bastian Venthur <venthur@debian.org> Mon, 11 Jun 2007 11:21:00 +0200
-
-tde-style-qtcurve (0.51-1) unstable; urgency=low
-
- * New upstream version (Closes: #427043)
-
- * Changed shading to use HSL colour space. This can be altered by editing
- $XDG_CONFIG_HOME/qtcurvestylerc and setting 'shading=simple' for the
- previous method, or 'shading=hsv' to use HSV.
- * Add options:
- Border all of menu/toolbars.
- Darker borders.
- 'V' arrows.
- * Fix raised listview headers.
- * Fix glass style menuitem appearance.
- * Modifed look of dullglass, looks "softer"
- * Improve look of plastik mouse-over for non coloured scrollbars.
- * For disabled buttons, use standard fill but lighten border.
- * Use darker colours for mouse-over and default button - helps with light
- colour schemes.
- * Dont draw sunken panel around checked menuitems.
- * Fix karm (and others?) statusbar icon.
- * Fix for radio buttons in apps where
- QApplication::NormalColor!=QApplication::colorSpec() (e.g. designer)
-
- -- Bastian Venthur <venthur@debian.org> Mon, 11 Jun 2007 10:42:01 +0200
-
-tde-style-qtcurve (0.50-1) unstable; urgency=low
-
- * Initial release
-
- -- Bastian Venthur <venthur@debian.org> Fri, 25 May 2007 12:38:49 +0200
-
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/compat b/ubuntu/precise/applications/tde-style-qtcurve/debian/compat
deleted file mode 100644
index 7ed6ff82d..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/control b/ubuntu/precise/applications/tde-style-qtcurve/debian/control
deleted file mode 100644
index f49755ce3..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/control
+++ /dev/null
@@ -1,31 +0,0 @@
-Source: tde-style-qtcurve-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-XSBC-Original-Maintainer: Bastian Venthur <venthur@debian.org>
-Build-Depends: debhelper (>= 5), quilt, tdelibs14-trinity-dev, cmake, cdbs
-Standards-Version: 3.8.4
-
-Package: tde-style-qtcurve-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: kde-style-qtcurve-kde3 (<< 4:14.0.0~), kde-style-qtcurve-trinity (<< 4:14.0.0~)
-Breaks: kde-style-qtcurve-kde3 (<< 4:14.0.0~), kde-style-qtcurve-trinity (<< 4:14.0.0~)
-Recommends: gtk2-engines-qtcurve
-Provides: tde-style-qtcurve
-Description: This is a set of widget styles for Trinity based apps
- This package together with gtk2-engines-qtcurve aim to provide a unified look
- and feel on the desktop when using KDE and Gnome applications.
- .
- This package is most useful when installed together with
- gtk2-engines-qtcurve.
-
-Package: qtcurve-trinity
-Architecture: any
-Depends: tde-style-qtcurve-trinity, gtk2-engines-qtcurve
-Replaces: qtcurve-kde3 (<< 4:14.0.0~), qtcurve-trinity (<< 4:14.0.0~)
-Breaks: qtcurve-kde3 (<< 4:14.0.0~), qtcurve-trinity (<< 4:14.0.0~)
-Description: This is a set of widget styles for Trinity and Gtk2 based apps
- This is an empty dummy package which will drag the packages
- tde-style-qtcurve and gtk2-engines-qtcurve in your system.
-
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/control.in b/ubuntu/precise/applications/tde-style-qtcurve/debian/control.in
deleted file mode 100644
index a3e92a938..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/control.in
+++ /dev/null
@@ -1,32 +0,0 @@
-Source: tde-style-qtcurve-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-XSBC-Original-Maintainer: @@@MAINTAINER@@@
-Uploaders: @@@UPLOADERS@@@
-Build-Depends: debhelper (>= 5), quilt, tdelibs14-trinity-dev, cmake, cdbs
-Standards-Version: 3.8.4
-
-Package: tde-style-qtcurve-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: tde-style-qtcurve-kde3 (<< 4:3.5.13)
-Breaks: tde-style-qtcurve-kde3 (<< 4:3.5.13)
-Recommends: gtk2-engines-qtcurve
-Provides: tde-style-qtcurve
-Description: This is a set of widget styles for Trinity based apps
- This package together with gtk2-engines-qtcurve aim to provide a unified look
- and feel on the desktop when using KDE and Gnome applications.
- .
- This package is most useful when installed together with
- gtk2-engines-qtcurve.
-
-Package: qtcurve-trinity
-Architecture: any
-Depends: tde-style-qtcurve-trinity, gtk2-engines-qtcurve
-Replaces: qtcurve-kde3 (<< 4:3.5.13)
-Breaks: qtcurve-kde3 (<< 4:3.5.13)
-Description: This is a set of widget styles for Trinity and Gtk2 based apps
- This is an empty dummy package which will drag the packages
- tde-style-qtcurve and gtk2-engines-qtcurve in your system.
-
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/copyright b/ubuntu/precise/applications/tde-style-qtcurve/debian/copyright
deleted file mode 100644
index 055d8a659..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/copyright
+++ /dev/null
@@ -1,33 +0,0 @@
-This package was debianized by Bastian Venthur <venthur@debian.org> on
-Fri, 25 May 2007 12:52:24 +0200.
-
-It was downloaded from <http://www.kde-look.org/content/show.php/QtCurve+%28KDE4%2C+Trinity%2C+%26+Gtk2+Theme%29?content=40492>
-
-Upstream Author:
-
- Craig Drummond <Craig.Drummond@lycos.co.uk>
-
-Copyright:
-
- Copyright (C) 2007 Craig Drummond
-
-License:
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public
- License along with this program; if not, write to the
- Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
- MA 02110-1301, USA.
-
-
-The Debian packaging is (C) 2007, Bastian Venthur <venthur@debian.org> and
-is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/docs b/ubuntu/precise/applications/tde-style-qtcurve/debian/docs
deleted file mode 100644
index 724e08449..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-README
-TODO
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/patches/series b/ubuntu/precise/applications/tde-style-qtcurve/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/patches/series
+++ /dev/null
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/rules b/ubuntu/precise/applications/tde-style-qtcurve/debian/rules
deleted file mode 100755
index 52bf17ae4..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/rules
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/make -f
-
-PATH := /opt/trinity/bin:$(PATH)
-
-# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
-# Also include the main Trinity path
-ifeq ("$(LD_LIBRARY_PATH)", "")
-LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
-else
-LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
-endif
-export LD_LIBRARY_PATH
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-include debian/cdbs/debian-qt-kde.mk
-
-DEB_KDE_APIDOX := yes
-
-CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
-
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
-# never build in parallel, regardless of DEB_BUILD_OPTIONS.
-DEB_BUILD_PARALLEL = true
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/scan-version b/ubuntu/precise/applications/tde-style-qtcurve/debian/scan-version
deleted file mode 100644
index 640ea27c7..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/scan-version
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/usr/bin/make -sf
-
-DL_LINK = http://www.kde-look.org/content/download.php?content=40492&id=2
-DL_LINK_REAL = $(shell LANG=C wget --spider "$(DL_LINK)" 2>&1 | grep "Location: " | sed "s/Location: //" | sed "s/ \[following\]//")
-PACKAGE = $(shell dpkg-parsechangelog | egrep '^Source: ' | sed s/"Source: "//)
-DEBIAN_VERSION = $(shell dpkg-parsechangelog | egrep '^Version: ' | sed s/"Version: "//)
-UPSTREAM_VERSION = $(shell echo $(DEBIAN_VERSION) | sed s/-.*//)
-FILE_NAME = $(shell echo "$(DL_LINK_REAL)" | sed s/\\//\\n/g | tail -n 1)
-FILE_EXT = $(shell echo "$(DL_LINK_REAL)" | sed s/\\./\\n/g | tail -n 1)
-NET_VERSION = $(shell echo "$(FILE_NAME)" | egrep -o "[0-9]+\.[0-9]+(\.[0-9]+)?")
-ORIG_TAR_GZ = ../$(PACKAGE)_$(NET_VERSION).orig.tar.gz
-
-all:
- echo "Usage: debian/scan-version {scan|download|get-orig-source}"
- exit 1
-
-scan:
- dh_testdir
- echo "URL: $(DL_LINK_REAL)"
- echo "File: $(FILE_NAME)"
- echo "Current version: $(UPSTREAM_VERSION)"
- echo "Available version: $(NET_VERSION)"
- echo
- echo "If the available version is higher, type \"debian/scan-version download\" to download it."
-
-download:
- dh_testdir
- echo "Downloading $(DL_LINK_REAL)..."
- wget $(DL_LINK_REAL) -O "../$(FILE_NAME)" 2> /dev/null
- echo "Successfully downloaded to ../$(FILE_NAME)"
-
-get-orig-source: download
- echo "Creating $(ORIG_TAR_GZ)..."
- if [ "$(FILE_EXT)" = "gz" ]; then \
- cp "../$(FILE_NAME)" "$(ORIG_TAR_GZ)"; \
- else \
- bunzip2 -c "../$(FILE_NAME)" | gzip -9c > "$(ORIG_TAR_GZ)"; \
- fi
- echo
-
-.PHONY: all parse-url scan download get-orig-source
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/source/format b/ubuntu/precise/applications/tde-style-qtcurve/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/source/options b/ubuntu/precise/applications/tde-style-qtcurve/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*
diff --git a/ubuntu/precise/applications/tde-style-qtcurve/debian/tde-style-qtcurve-trinity.install b/ubuntu/precise/applications/tde-style-qtcurve/debian/tde-style-qtcurve-trinity.install
deleted file mode 100644
index 003761370..000000000
--- a/ubuntu/precise/applications/tde-style-qtcurve/debian/tde-style-qtcurve-trinity.install
+++ /dev/null
@@ -1 +0,0 @@
-debian/tmp/opt