summaryrefslogtreecommitdiffstats
path: root/ubuntu/precise/applications/tdeio-umountwrapper/debian
diff options
context:
space:
mode:
Diffstat (limited to 'ubuntu/precise/applications/tdeio-umountwrapper/debian')
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/buildvars.mk86
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk111
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/kde.mk97
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/team-members16
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/uploaders.mk29
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/versions.pl19
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/changelog71
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/compat1
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/control17
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/copyright30
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop74
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/patches/series0
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/postrm54
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/preinst90
-rwxr-xr-xubuntu/precise/applications/tdeio-umountwrapper/debian/rules49
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/source/format1
-rw-r--r--ubuntu/precise/applications/tdeio-umountwrapper/debian/source/options6
17 files changed, 0 insertions, 751 deletions
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/buildvars.mk b/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/buildvars.mk
deleted file mode 100644
index 23d4709dc..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/buildvars.mk
+++ /dev/null
@@ -1,86 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2002,2003 Colin Walters <walters@debian.org>
-# Description: Defines some useful variables, but no rules
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_rules_buildvars
-_cdbs_rules_buildvars = 1
-
-CDBS_VERSION = something
-
-# Common useful variables
-DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
-DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
-DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
-DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
-DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
-
-# Split into arch/indep packages
-ifneq ($(DEB_INDEP_PACKAGES),cdbs)
-DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
-DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
-endif
-# Split into normal and udeb packages
-ifeq ($(DEB_UDEB_PACKAGES),)
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-else
-DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-endif
-# Too much bother for now. If someone complains we'll fix it.
-#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
-#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
-# A handy list of every package, udeb or not
-DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
-DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
-DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
-
-DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
-
-# Some support for srcdir != builddir builds.
-# These are relative to the root of the package
-DEB_SRCDIR ?= .
-DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
-
-# Miscellaneous bits
-DEB_ARCH = $(shell dpkg --print-architecture)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
-DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
-DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
-DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
-
-ifeq ($(words $(DEB_ALL_PACKAGES)),1)
- DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
-else
- DEB_DESTDIR = $(CURDIR)/debian/tmp/
-endif
-
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
-
-endif
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk b/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk
deleted file mode 100644
index c807eed8c..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/debian-qt-kde.mk
+++ /dev/null
@@ -1,111 +0,0 @@
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
- touch debian/stamp-cvs-make
-
-include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
-include debian/cdbs/uploaders.mk
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-clean::
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/kde.mk b/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/kde.mk
deleted file mode 100644
index 765560c89..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/kde.mk
+++ /dev/null
@@ -1,97 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Description: A class for KDE packages; sets KDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-
-ifndef _cdbs_class_kde
-_cdbs_class_kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-common-build-arch common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-prehook-impl::
- mkdir -p po
- -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
- -for file in po/*pot; do \
- sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
- done
-
-common-install-arch common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-clean::
- rm -f debian/stamp-kde-apidox
- rm -rf po/*.pot
-
-# This is a convenience target for calling manually. It's not part of
-# the build process.
-buildprep: clean apply-patches
- $(MAKE) -f admin/Makefile.common dist
- debian/rules clean
-
-endif
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/team-members b/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/team-members
deleted file mode 100644
index 05761af6e..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/team-members
+++ /dev/null
@@ -1,16 +0,0 @@
-Sune Vuorela <debian@pusling.com>
-Ana Beatriz Guerrero Lopez <ana@debian.org>
-Fathi Boudra <fboudra@free.fr>
-Modestas Vainius <geromanas@mailas.com>
-Josh Metzler <joshdeb@metzlers.org>
-Isaac Clerencia <isaac@debian.org>
-Adeodato Simó <dato@net.com.org.es>
-Adeodato Simo <dato@net.com.org.es>
-Christopher Martin <chrsmrtn@debian.org>
-Daniel Schepler <schepler@debian.org>
-Sarah Hobbs <hobbsee@ubuntu.com>
-Nacho Barrientos Arias <nacho@debian.org>
-Ricardo Javier Cardenes Medina <rcardenes@debian.org>
-Ricardo Cardenes <rcardenes@debian.org>
-Armin Berres <trigger+debian@space-based.de>
-Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/uploaders.mk b/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/uploaders.mk
deleted file mode 100644
index 31adfe31e..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/uploaders.mk
+++ /dev/null
@@ -1,29 +0,0 @@
-
-MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
-
-
-debian/control.tmp:
- @if [ ! -e debian/control.in ] ; then \
- echo "this package is not yet prepared for using automatic update of uploaders"; \
- echo "Please do so."; \
- exit 1; \
- fi
- @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
-
-check-uploaders: debian/control.tmp
- @if ! diff -q debian/control debian/control.tmp ; then \
- echo "WARNING:: Control file differs from manually generated one" ; \
- echo "WARNING:: Please update it manually and check it afterwards" ; \
- echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
- echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
- fi
-
-
-clean::
- rm -f debian/control.tmp
-
-update-uploaders: debian/control.tmp
- @mv -f debian/control.tmp debian/control
-
-makebuilddir:: check-uploaders
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/versions.pl b/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/versions.pl
deleted file mode 100644
index 75c9add4b..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "KDE-Version3=$version3\n";
-print "KDE-Version2=$version2\n";
-print "KDE-Next-Version3=$version3_next\n";
-print "KDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/changelog b/ubuntu/precise/applications/tdeio-umountwrapper/debian/changelog
deleted file mode 100644
index 70a661d55..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/changelog
+++ /dev/null
@@ -1,71 +0,0 @@
-tdeio-umountwrapper-trinity (0.2-1ubuntu3) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
-
-tdeio-umountwrapper-trinity (0.2-1ubuntu2) intrepid; urgency=low
-
- * Moved Trinity to /opt/trinity
- * Integrated properly with KDE4.2+
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 05 March 2009 29:52:00 -0600
-
-tdeio-umountwrapper-trinity (0.2-0ubuntu3) intrepid; urgency=low
-
- * Added -trinity suffix
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 31 Dec 2008 14:46:00 -0600
-
-kio-umountwrapper (0.2-0ubuntu6.2) hardy-proposed; urgency=low
-
- * Fix syntax in postrm
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 27 Aug 2008 00:00:03 +0100
-
-kio-umountwrapper (0.2-0ubuntu6.1) hardy-proposed; urgency=low
-
- * debian/preinst, debian/postrm: make sure than the directories used by
- dpkg-divert exist
-
- -- Gauvain Pocentek <gauvain@ulteo.com> Sun, 29 Jun 2008 11:06:10 +0200
-
-kio-umountwrapper (0.2-0ubuntu6) hardy; urgency=low
-
- * Update from Jan Klötzke to also support encrypted removable drives
- correctly, closes LP: #186841
-
- -- Jonathan Riddell <jriddell@ubuntu.com> Wed, 06 Feb 2008 16:04:46 +0000
-
-kio-umountwrapper (0.2-0ubuntu5) hardy; urgency=low
-
- * Do not try to divert /usr/../dolphin/../media_safelyremove.desktop,
- since dolphin doesn't install that anymore. (LP: #183292)
-
- -- Timo Aaltonen <tepsipakki@ubuntu.com> Mon, 28 Jan 2008 13:28:39 +0200
-
-kio-umountwrapper (0.2-0ubuntu4) hardy; urgency=low
-
- * Fix build failure with g++-4.3.
-
- -- Matthias Klose <doko@ubuntu.com> Thu, 24 Jan 2008 09:44:46 +0000
-
-kio-umountwrapper (0.2-0ubuntu3) gutsy; urgency=low
-
- * Add kdepot patch for translations.
- * Change maintainer to Ubuntu Core Dev.
-
- -- Frode M. Døving <frode@ubuntu.com> Mon, 23 Jul 2007 00:00:21 +0200
-
-kio-umountwrapper (0.2-0ubuntu2) gutsy; urgency=low
-
- * Add d3lphin support, as the dolphin package in gutsy is actually patched
- to become d3lphin.
-
- -- Frode M. Døving <frode@ubuntu.com> Sun, 22 Jul 2007 22:40:54 +0200
-
-kio-umountwrapper (0.2-0ubuntu1) gutsy; urgency=low
-
- * Initial release.
-
- -- Frode M. Døving <frode@ubuntu.com> Thu, 31 May 2007 14:05:33 +0200
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/compat b/ubuntu/precise/applications/tdeio-umountwrapper/debian/compat
deleted file mode 100644
index 7ed6ff82d..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/control b/ubuntu/precise/applications/tdeio-umountwrapper/debian/control
deleted file mode 100644
index 6db9b241e..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/control
+++ /dev/null
@@ -1,17 +0,0 @@
-Source: tdeio-umountwrapper-trinity
-Section: tde
-Priority: optional
-Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: debhelper (>> 5), quilt, cdbs, tdelibs14-trinity-dev, automake, autoconf, libtool, libltdl-dev
-Standards-Version: 3.8.4
-
-Package: tdeio-umountwrapper-trinity
-Architecture: any
-Depends: ${shlibs:Depends}
-Replaces: kio-umountwrapper-kde3 (<< 4:14.0.0~), kio-umountwrapper-trinity (<< 4:14.0.0~)
-Breaks: kio-umountwrapper-kde3 (<< 4:14.0.0~), kio-umountwrapper-trinity (<< 4:14.0.0~)
-Description: progress dialog for safely removing devices in Trinity.
- Wrapper around tdeio_media_mountwrapper.
- Provides a progress dialog for Safely Removing of devices in Trinity.
- .
- Homepage: http://frode.kde.no/misc/tdeio_umountwrapper/
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/copyright b/ubuntu/precise/applications/tdeio-umountwrapper/debian/copyright
deleted file mode 100644
index 08e471ac6..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/copyright
+++ /dev/null
@@ -1,30 +0,0 @@
-This package was debianized by Frode M. Dving <frode@lnix.net>
-on Tue, 10-May-2007 20:55:10 +0200
-
-Upstream authors are
-
- Frode M. Dving <frode@lnix.net>
-
-License:
-
- All files are licenced GPL v2 or later
-
- This program is free software; you can redistribute it and/or
- modify it under the terms of the GNU General Public
- License as published by the Free Software Foundation; either
- version 2 of the License, or (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-
- On Debian GNU/Linux systems, the complete text of the GNU General
- Public License can be found in `/usr/share/common-licenses/GPL'.
-
- The Debian packaging is under the same license as the program.
-
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop b/ubuntu/precise/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop
deleted file mode 100644
index 38fa25d92..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/media_safelyremove.desktop
+++ /dev/null
@@ -1,74 +0,0 @@
-[Desktop Entry]
-ServiceTypes=media/removable_mounted,media/removable_mounted_decrypted,media/removable_unmounted,media/removable_unmounted_decrypted,media/camera_mounted,media/camera_unmounted
-Actions=MediaSafelyRemove;
-X-TDE-Priority=TopLevel
-X-TDE-MediaNotifierHide=true
-
-[Desktop Action MediaSafelyRemove]
-Name=Safely Remove
-Name[af]=Verwyder veilig
-Name[ar]=أحذف بأمان
-Name[be]=Бяспечна адлучыць
-Name[bg]=Безопасно изваждане
-Name[bn]=নিরাপদভাবে সরাও
-Name[bs]=Sigurno ukloni
-Name[ca]=Extreu amb seguretat
-Name[cs]=Bezpečně odstranit
-Name[csb]=Remôj na bezpieczny ôrt
-Name[da]=Fjern sikkert
-Name[de]=Sicher entfernen
-Name[el]=Ασφαλής αφαίρεση
-Name[eo]=Sekura Forigo
-Name[es]=Extracción segura
-Name[et]=Eemalda turvaliselt
-Name[eu]=Atera arriskurik gabe
-Name[fa]=حذف امن
-Name[fi]=Poista turvallisesti
-Name[fr]=Enlever en toute sécurité
-Name[fy]=Feilich ferwiderje
-Name[ga]=Bain Amach go Sábháilte
-Name[gl]=Eliminar de Maneira Segura
-Name[he]=שליפה בבטחה
-Name[hr]=Slobodno uklonite
-Name[hu]=Biztonságos leválasztás
-Name[is]=Fjarlægja öruggt
-Name[it]=Rimozione sicura
-Name[ja]=安全に取り除く
-Name[kk]=Қауіпсіз алып шығу
-Name[km]=យកចេញ​ដោយ​សុវត្ថិភាព
-Name[lt]=Saugiai pašalinti
-Name[mk]=Безбедно отстрани
-Name[ms]=Buang Dengan Selamat
-Name[nb]=Sikker fjerning
-Name[nds]=Seker rutnehmen
-Name[ne]=सुरक्षीत रुपमा हटाउनुहोस्
-Name[nl]=Veilig verwijderen
-Name[nn]=Trygg fjerning
-Name[pa]=ਸੁਰੱਖਿਅਤ ਹਟਾਓ
-Name[pl]=Usuń w sposób bezpieczny
-Name[pt]=Retirar com Segurança
-Name[pt_BR]=Remover de Modo Seguro
-Name[ro]=Scoate în siguranță
-Name[ru]=Безопасно извлечь
-Name[rw]=Gukuramo Neza
-Name[se]=Dorvvošlaš eretváldin
-Name[sk]=Bezpečne odpojiť
-Name[sl]=Varno odstrani
-Name[sr]=Безбедно уклони
-Name[sr@Latn]=Bezbedno ukloni
-Name[sv]=Säker urkoppling
-Name[ta]=பாதுகாப்பாக நீக்கு
-Name[te]=జాగరత్తగా తియి
-Name[tg]=Баровардани бехетар
-Name[th]=ถอดออกอย่างปลอดภัย
-Name[tr]=Güvenli Kaldır
-Name[tt]=İmin Çığaru
-Name[uk]=Безпечно вилучити
-Name[uz]=Эҳтиётлик билан узиш
-Name[vi]=Gỡ ra An toàn
-Name[wa]=Ositer e såvrité
-Name[zh_CN]=安全删除
-Name[zh_TW]=安全的移除
-Exec=tdeio_umountwrapper %u
-
-X-Ubuntu-Gettext-Domain=desktop_tdebase
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/patches/series b/ubuntu/precise/applications/tdeio-umountwrapper/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/patches/series
+++ /dev/null
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/postrm b/ubuntu/precise/applications/tdeio-umountwrapper/debian/postrm
deleted file mode 100644
index 9a4c04dbd..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/postrm
+++ /dev/null
@@ -1,54 +0,0 @@
-#! /bin/sh
-# -*- Mode: Sh -*-
-# Author: Frode M. Døving <frode@lnix.net> (C) 2007
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-set -e
-
-package_name=tdeio-umountwrapper-trinity
-
-# make sure than the directories exist before running dpkg-divert
-mkdir -p /opt/trinity/share/apps/konqueror/servicemenus/
-mkdir -p /opt/trinity/share/apps/dolphin/servicemenus/
-mkdir -p /opt/trinity/share/apps/d3lphin/servicemenus/
-
-case "$1" in
- remove)
- dpkg-divert --package $package_name --rename --remove \
- /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
-
- dpkg-divert --package $package_name --rename --remove \
- /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
-
- dpkg-divert --package $package_name --rename --remove \
- /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
-
- # try to remove the dirs we've created for pkg-divert
- rmdir --ignore-fail-on-non-empty /opt/trinity/share/apps/konqueror/servicemenus/
- rmdir --ignore-fail-on-non-empty /opt/trinity/share/apps/dolphin/servicemenus/
- rmdir --ignore-fail-on-non-empty /opt/trinity/share/apps/d3lphin/servicemenus/
- ;;
-
- upgrade)
- exit 0
- ;;
-
- *) echo "$0: didn't understand being called with \`$1'" 1>&2
- exit 0;;
-esac
-
-exit 0
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/preinst b/ubuntu/precise/applications/tdeio-umountwrapper/debian/preinst
deleted file mode 100644
index a258f8481..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/preinst
+++ /dev/null
@@ -1,90 +0,0 @@
-#! /bin/sh
-# -*- Mode: Sh -*-
-# Author: Frode M. Døving <frode@lnix.net> (C) 2007
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-#
-
-set -e
-
-package_name=tdeio-umountwrapper-trinity
-
-# make sure than the directories exist before running dpkg-divert
-mkdir -p /opt/trinity/share/apps/konqueror/servicemenus/
-mkdir -p /opt/trinity/share/apps/dolphin/servicemenus/
-mkdir -p /opt/trinity/share/apps/d3lphin/servicemenus/
-
-case "$1" in
- install)
- # remove old diversions if present
- divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop"`
- if [ -n "$divert" ] && [ "$divert" = "kio-umountwrapper-trinity" ]; then
- dpkg-divert --package kio-umountwrapper-trinity --rename --remove /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
- fi
- divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop"`
- if [ -n "$divert" ] && [ "$divert" = "kio-umountwrapper-trinity" ]; then
- dpkg-divert --package kio-umountwrapper-trinity --rename --remove /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
- fi
- divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop"`
- if [ -n "$divert" ] && [ "$divert" = "kio-umountwrapper-trinity" ]; then
- dpkg-divert --package kio-umountwrapper-trinity --rename --remove /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
- fi
-
- # add new diversions
- dpkg-divert --package $package_name \
- --divert /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop.distrib \
- --rename /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
-
- dpkg-divert --package $package_name \
- --divert /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop.distrib \
- --rename /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
-
- dpkg-divert --package $package_name \
- --divert /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop.distrib \
- --rename /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
-
- ;;
- upgrade)
- divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop"`
- if [ -z "$divert" ]; then
- dpkg-divert --package $package_name \
- --divert /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop.distrib \
- --rename /opt/trinity/share/apps/konqueror/servicemenus/media_safelyremove.desktop
- fi
-
- divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop"`
- if [ -z "$divert" ]; then
- dpkg-divert --package $package_name \
- --divert /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop.distrib \
- --rename /opt/trinity/share/apps/dolphin/servicemenus/media_safelyremove.desktop
- fi
-
- divert=`dpkg-divert --listpackage "/opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop"`
- if [ -z "$divert" ]; then
- dpkg-divert --package $package_name \
- --divert /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop.distrib \
- --rename /opt/trinity/share/apps/d3lphin/servicemenus/media_safelyremove.desktop
- fi
-
- exit 0
- ;;
-
- *) echo "$0: didn't understand being called with \`$1'" 1>&2
- exit 0
- ;;
-esac
-
-exit 0
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/rules b/ubuntu/precise/applications/tdeio-umountwrapper/debian/rules
deleted file mode 100755
index e3f6c6049..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/rules
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include debian/cdbs/kde.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- ! [ -f /usr/share/libtool/ltmain.sh ] || \
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
- ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
-common-post-build-arch::
- XGETTEXT=/usr/bin/kde-xgettext sh admin/cvs.sh extract-messages
-
-install/tdeio-umountwrapper-trinity::
- mkdir -p $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/konqueror/servicemenus/
- cp $(CURDIR)/debian/media_safelyremove.desktop \
- $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/konqueror/servicemenus/
-
- mkdir -p $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/dolphin/servicemenus/
- cp $(CURDIR)/debian/media_safelyremove.desktop \
- $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/dolphin/servicemenus/
-
- mkdir -p $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/d3lphin/servicemenus/
- cp $(CURDIR)/debian/media_safelyremove.desktop \
- $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/d3lphin/servicemenus/
-clean::
- rm -rf $(CURDIR)/debian/tdeio-umountwrapper-trinity/opt/trinity/share/apps/
- rm -f po/*.pot
-
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/source/format b/ubuntu/precise/applications/tdeio-umountwrapper/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/precise/applications/tdeio-umountwrapper/debian/source/options b/ubuntu/precise/applications/tdeio-umountwrapper/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/precise/applications/tdeio-umountwrapper/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*