summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:19:41 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 12:04:10 +0900
commit53c0b7bcf6c3e390b2e18af83d3979d302921efe (patch)
tree9eea76bde9641783e7429504904c3426fc8e3907 /CMakeLists.txt
parent7febd6678daafb42bfb00335211b319a0ce34458 (diff)
downloadtdegraphics-53c0b7bcf6c3e390b2e18af83d3979d302921efe.tar.gz
tdegraphics-53c0b7bcf6c3e390b2e18af83d3979d302921efe.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6196a003..bd185441 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -33,11 +38,6 @@ include( CheckSymbolExists )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )