summaryrefslogtreecommitdiffstats
path: root/ksvg/plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /ksvg/plugin/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ksvg/plugin/CMakeLists.txt')
-rw-r--r--ksvg/plugin/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/ksvg/plugin/CMakeLists.txt b/ksvg/plugin/CMakeLists.txt
index 08078eb5..360bae35 100644
--- a/ksvg/plugin/CMakeLists.txt
+++ b/ksvg/plugin/CMakeLists.txt
@@ -39,9 +39,13 @@ install( FILES
##### other data ################################
-install( FILES
- ksvgplugin.desktop svgthumbnail.desktop
- DESTINATION ${SERVICES_INSTALL_DIR} )
+foreach( _service ksvgplugin.desktop svgthumbnail.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_service}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/ksvg-desktops
+ )
+endforeach()
install( FILES
ksvgplugin.rc