summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-02 23:06:07 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-02 23:06:07 +0000
commit75c0180e447ff3602e2340c6bf043835838c7997 (patch)
tree03d24dd04c376d76177924d738e4405b63b29393 /CMakeLists.txt
parent844e4d4e9175ce1dc2d2c4c0bd39ca67e02d6a64 (diff)
downloadamarok-75c0180e447ff3602e2340c6bf043835838c7997.tar.gz
amarok-75c0180e447ff3602e2340c6bf043835838c7997.zip
[amarok] all media devices ported to cmake
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/amarok@1230244 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8feed576..e214d289 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ project( amarok )
include( CheckCXXSourceCompiles )
include( CheckFunctionExists )
include( CheckIncludeFileCXX )
+include( CheckLibraryExists )
include( CheckStructHasMember )
include( CheckSymbolExists )
include( CheckTypeSize )
@@ -45,7 +46,12 @@ tde_setup_paths( )
option( WITH_LIBVISUAL "Enable libvisual support" OFF )
option( WITH_KONQSIDEBAR "Enable konqsidebar plugin" OFF )
option( WITH_XINE "Enable xine-engine support" OFF )
-option( WITH_LIBGPOD "Enable iPod support from libgpod" OFF )
+option( WITH_IPOD "Enable iPod support from libgpod" OFF )
+option( WITH_IFP "Enable ifp support" OFF )
+option( WITH_NJB "Enable njb support" OFF )
+option( WITH_MTP "Enable mtp support" OFF )
+option( WITH_RIOKARMA "Enable riokarma support" OFF )
+option( WITH_DAAP "Enable daap support" OFF )
##### user requested modules ####################