summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8feed576..e214d289 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ project( amarok )
include( CheckCXXSourceCompiles )
include( CheckFunctionExists )
include( CheckIncludeFileCXX )
+include( CheckLibraryExists )
include( CheckStructHasMember )
include( CheckSymbolExists )
include( CheckTypeSize )
@@ -45,7 +46,12 @@ tde_setup_paths( )
option( WITH_LIBVISUAL "Enable libvisual support" OFF )
option( WITH_KONQSIDEBAR "Enable konqsidebar plugin" OFF )
option( WITH_XINE "Enable xine-engine support" OFF )
-option( WITH_LIBGPOD "Enable iPod support from libgpod" OFF )
+option( WITH_IPOD "Enable iPod support from libgpod" OFF )
+option( WITH_IFP "Enable ifp support" OFF )
+option( WITH_NJB "Enable njb support" OFF )
+option( WITH_MTP "Enable mtp support" OFF )
+option( WITH_RIOKARMA "Enable riokarma support" OFF )
+option( WITH_DAAP "Enable daap support" OFF )
##### user requested modules ####################