summaryrefslogtreecommitdiffstats
path: root/acl-updater/plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-04-03 18:19:30 +0200
committergregory guy <g-gregory@gmx.fr>2019-04-05 17:11:45 +0200
commit307a1a53261669dc8d1d2ee031a8927f64ddb27a (patch)
treec7b4aa825a12858f3c4fffc0bc7fda19a9102ca3 /acl-updater/plugin/CMakeLists.txt
parentf0e9b7cf4f429387055108e3c94b9bfc39c5fba0 (diff)
downloadkcmldapcontroller-307a1a53.tar.gz
kcmldapcontroller-307a1a53.zip
conversion to the cmake building system
Signed-off-by: gregory guy <g-gregory@gmx.fr>
Diffstat (limited to 'acl-updater/plugin/CMakeLists.txt')
-rw-r--r--acl-updater/plugin/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/acl-updater/plugin/CMakeLists.txt b/acl-updater/plugin/CMakeLists.txt
new file mode 100644
index 0000000..d9bf81d
--- /dev/null
+++ b/acl-updater/plugin/CMakeLists.txt
@@ -0,0 +1,31 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}/tde
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### slapi-acl-manager (module)
+
+tde_add_library( slapi-acl-manager MODULE
+
+ SOURCES
+ interface.c
+ plugin.cpp
+ LINK
+ tdecore-shared
+ ${TDELDAP_LIBRARIES}
+ ${KRB5_LIBRARIES}
+ ${SLAPI_LIBRARIES}
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)