summaryrefslogtreecommitdiffstats
path: root/acl-updater/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'acl-updater/plugin/CMakeLists.txt')
-rw-r--r--acl-updater/plugin/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/acl-updater/plugin/CMakeLists.txt b/acl-updater/plugin/CMakeLists.txt
new file mode 100644
index 0000000..d9bf81d
--- /dev/null
+++ b/acl-updater/plugin/CMakeLists.txt
@@ -0,0 +1,31 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}/tde
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### slapi-acl-manager (module)
+
+tde_add_library( slapi-acl-manager MODULE
+
+ SOURCES
+ interface.c
+ plugin.cpp
+ LINK
+ tdecore-shared
+ ${TDELDAP_LIBRARIES}
+ ${KRB5_LIBRARIES}
+ ${SLAPI_LIBRARIES}
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)