summaryrefslogtreecommitdiffstats
path: root/conduits/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/Makefile.am
downloadkpilot-cb7eddb9.tar.gz
kpilot-cb7eddb9.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/Makefile.am')
-rw-r--r--conduits/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/conduits/Makefile.am b/conduits/Makefile.am
new file mode 100644
index 0000000..fed4498
--- /dev/null
+++ b/conduits/Makefile.am
@@ -0,0 +1,30 @@
+###
+### The NULL conduit is a neat programming example, but shouldn't be
+### installed on user systems.
+###
+
+if include_malconduit
+MAL_SUBDIR = malconduit
+else
+MAL_SUBDIR =
+endif
+
+SUBDIRS = \
+ abbrowserconduit \
+ docconduit \
+ knotes \
+ $(MAL_SUBDIR) \
+ memofileconduit \
+ notepadconduit \
+ popmail \
+ sysinfoconduit \
+ timeconduit \
+ vcalconduit
+
+###
+### Subdirs you might have for experimental purposes:
+###
+### null - a conduit that just logs a single message.
+### $(PERL_SUBDIR) - fires off a perl interpreter in a thread.
+### $(PYTHON_SUBDIR) - starts a python interpreter in a thread.
+###