summaryrefslogtreecommitdiffstats
path: root/conduits/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'conduits/Makefile.am')
-rw-r--r--conduits/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/conduits/Makefile.am b/conduits/Makefile.am
new file mode 100644
index 0000000..fed4498
--- /dev/null
+++ b/conduits/Makefile.am
@@ -0,0 +1,30 @@
+###
+### The NULL conduit is a neat programming example, but shouldn't be
+### installed on user systems.
+###
+
+if include_malconduit
+MAL_SUBDIR = malconduit
+else
+MAL_SUBDIR =
+endif
+
+SUBDIRS = \
+ abbrowserconduit \
+ docconduit \
+ knotes \
+ $(MAL_SUBDIR) \
+ memofileconduit \
+ notepadconduit \
+ popmail \
+ sysinfoconduit \
+ timeconduit \
+ vcalconduit
+
+###
+### Subdirs you might have for experimental purposes:
+###
+### null - a conduit that just logs a single message.
+### $(PERL_SUBDIR) - fires off a perl interpreter in a thread.
+### $(PYTHON_SUBDIR) - starts a python interpreter in a thread.
+###