summaryrefslogtreecommitdiffstats
path: root/kpilot/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-11-30 11:53:24 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-12-02 12:22:20 +0100
commit7a58626b341481c8e37cf5a8b9b961107c8ab0ac (patch)
treebab45e0b223ef2afbf95f7fc58f4f9ecb1a415d4 /kpilot/CMakeLists.txt
parente365033d55c6264b3fece6bb85616553dab7d61e (diff)
downloadkpilot-7a58626b.tar.gz
kpilot-7a58626b.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Use common rules for build and install documentation. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kpilot/CMakeLists.txt')
-rw-r--r--kpilot/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/kpilot/CMakeLists.txt b/kpilot/CMakeLists.txt
index dbd268e..44ee55d 100644
--- a/kpilot/CMakeLists.txt
+++ b/kpilot/CMakeLists.txt
@@ -73,7 +73,8 @@ install( FILES kpilotui.rc
DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}
)
-install( FILES kpilot.desktop kpilotdaemon.desktop
+tde_create_translated_desktop(
+ SOURCE kpilot.desktop kpilotdaemon.desktop
DESTINATION ${XDG_APPS_INSTALL_DIR}
)
@@ -81,11 +82,13 @@ install( FILES kpilot.upd
DESTINATION ${DATA_INSTALL_DIR}/tdeconf_update
)
-install( FILES kpilot_config.desktop
+tde_create_translated_desktop(
+ SOURCE kpilot_config.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
)
-install( FILES kpilotconduit.desktop
+tde_create_translated_desktop(
+ SOURCE kpilotconduit.desktop
DESTINATION ${SERVICETYPES_INSTALL_DIR}
)