summaryrefslogtreecommitdiffstats
path: root/po/modules/editor/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-24 02:13:59 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-24 02:13:59 +0000
commita6d58bb6052ac8cb01805a48c4ad2f129126116f (patch)
treedd867a099fcbb263a8009a9fb22695b87855dad6 /po/modules/editor/Makefile.am
downloadkvirc-a6d58bb6052ac8cb01805a48c4ad2f129126116f.tar.gz
kvirc-a6d58bb6052ac8cb01805a48c4ad2f129126116f.zip
Added KDE3 version of kvirc
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kvirc@1095341 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'po/modules/editor/Makefile.am')
-rw-r--r--po/modules/editor/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/po/modules/editor/Makefile.am b/po/modules/editor/Makefile.am
new file mode 100644
index 0000000..ebe7b67
--- /dev/null
+++ b/po/modules/editor/Makefile.am
@@ -0,0 +1,74 @@
+################################################################################
+# KVirc IRC client Makefile - 18.09.99 Szymon Stefanek <pragma at kvirc dot net>
+################################################################################
+
+# The name of this module
+THISMODULE = editor
+
+# Don't touch this
+tmpdir = $(localedir)
+
+# The *.mo files to generate
+tmp_DATA = editor_ca.mo \
+ editor_cs.mo \
+ editor_it.mo \
+ editor_de.mo \
+ editor_es.mo \
+ editor_pt.mo \
+ editor_ru.mo \
+ editor_pt_BR.mo \
+ editor_fr.mo \
+ editor_hu.mo \
+ editor_fi.mo \
+ editor_uk.mo
+
+# The *.po files to generate
+POFILES = editor_ca.po \
+ editor_cs.po \
+ editor_it.po \
+ editor_de.po \
+ editor_es.po \
+ editor_pt.po \
+ editor_ru.po \
+ editor_pt_BR.po \
+ editor_fr.po \
+ editor_hu.po \
+ editor_fi.po \
+ editor_uk.po
+
+###############################################################################
+# STOP EDITING HERE
+###############################################################################
+
+# Killed the fuzzy entries: don't use them , they may SEGV
+# - touch $@ && $(SS_MSGFMT) -fvo $@ $<
+
+CLEANFILES = $(tmp_DATA)
+EXTRA_DIST = $(POFILES)
+
+%.mo: %.po
+ -touch $@ && $(SS_MSGFMT) -vo $@ $<
+
+messages-extract:
+ @find $(topdir)/src/modules/$(THISMODULE)/ -maxdepth 10 -name *.cpp > files; \
+ find $(topdir)/src/modules/$(THISMODULE)/ -maxdepth 10 -name *.h >> files; \
+ xgettext -o $(topdir)/po/modules/$(THISMODULE)/$(THISMODULE).pot -k__tr_ctx -k__tr_no_lookup_ctx -k__tr2qs_ctx -k__tr2wc_ctx -k__tr2ws_ctx -f files; \
+ rm files; \
+ echo "Messages extracted to $(THISMODULE).pot";
+
+messages-update:
+ @old=_old; \
+ if test -f "$(topdir)/po/modules/$(THISMODULE)/$(THISMODULE).pot"; then \
+ for lang in $(POFILES); do \
+ echo "Updating file $$lang"; \
+ mv -f $$lang $$lang$$old; \
+ msgmerge -o $$lang $$lang$$old $(topdir)/po/modules/$(THISMODULE)/$(THISMODULE).pot && rm -f $$lang$$old; \
+ done; \
+ else \
+ echo "----------------------------------------------------"; \
+ echo "- WARNING: ./$(THISMODULE).pot does not exist"; \
+ echo "- WARNING: You must run make messages-extract first"; \
+ echo "----------------------------------------------------"; \
+ fi
+
+messages: messages-extract messages-update