summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-09-11 22:50:09 +0300
committerChristian Beier <dontmind@freeshell.org>2012-09-14 18:46:52 +0200
commit539b310b48e2f9b685a5418f01ecf6257ef6452e (patch)
tree2ca80ac45f4abb7a6096ce5e728b9306440cf931 /CMakeLists.txt
parent2b4f616d96f92dc6596f8f4836582048dd57a3a5 (diff)
downloadlibtdevnc-539b310b48e2f9b685a5418f01ecf6257ef6452e.tar.gz
libtdevnc-539b310b48e2f9b685a5418f01ecf6257ef6452e.zip
CMake: Link against libgcrypt when it is found.
So far, libgcrypt was looked for but no targets linked against it directly; this caused linking problems for the client and server examples, as the symbols they needed were not passed to the linker. The issue that the GnuTLS websockets code uses libgcrypt regardless of whether it has been found or not has not been touched by this commit, though.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aaa6029..4648eec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,6 +107,7 @@ endif()
if(LIBGCRYPT_LIBRARIES)
message(STATUS "Found libgcrypt: ${LIBGCRYPT_LIBRARIES}")
set(LIBVNCSERVER_WITH_CLIENT_GCRYPT 1)
+ set(ADDITIONAL_LIBS ${ADDITIONAL_LIBS} ${LIBGCRYPT_LIBRARIES})
endif(LIBGCRYPT_LIBRARIES)
@@ -259,7 +260,7 @@ endif(LIBVNCSERVER_WITH_WEBSOCKETS)
add_library(vncclient SHARED ${LIBVNCCLIENT_SOURCES})
add_library(vncserver SHARED ${LIBVNCSERVER_SOURCES})
if(WIN32)
- set(ADDITIONAL_LIBS ws2_32)
+ set(ADDITIONAL_LIBS ${ADDITIONAL_LIBS} ws2_32)
endif(WIN32)
target_link_libraries(vncclient