summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2017-02-21 17:21:42 +0100
committerChristian Beier <dontmind@freeshell.org>2017-02-21 17:21:42 +0100
commit9198875122ddd9ca33231a6948d7244f8eb19d5f (patch)
treea78d1739601a99cf10a3d276ea7ab192def36dcc /CMakeLists.txt
parentf21825bac0cc60efb300fe0edaf351c48adb1fb1 (diff)
downloadlibtdevnc-9198875122ddd9ca33231a6948d7244f8eb19d5f.tar.gz
libtdevnc-9198875122ddd9ca33231a6948d7244f8eb19d5f.zip
CMake: enable the tests that succeed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 125155f..f1e2512 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,8 @@ include(CheckCSourceCompiles)
include(CheckCXXSourceCompiles)
include(CheckCSourceRuns)
+enable_testing()
+
set(PACKAGE_NAME "LibVNCServer")
set(FULL_PACKAGE_NAME "LibVNCServer")
set(VERSION_MAJOR "0")
@@ -524,6 +526,8 @@ if(FOUND_LIBJPEG_TURBO)
endif(FOUND_LIBJPEG_TURBO)
+add_test(NAME cargs COMMAND test_cargstest)
+add_test(NAME turbojpeg COMMAND test_tjunittest)