summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-06-22 13:03:56 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-06-22 13:04:25 +0200
commita3628aa81ce04b74b10732a3ce08fb41c91657f0 (patch)
tree3b0f2296324575878581d0afc9b330aa4231f1d0 /CMakeLists.txt
parent6fbd5fcdf1b145af2c145c1526fda1f809c8827b (diff)
downloadlibtdevnc-a3628aa81ce04b74b10732a3ce08fb41c91657f0.tar.gz
libtdevnc-a3628aa81ce04b74b10732a3ce08fb41c91657f0.zip
Fix FTBFS due to new DSO linkage style
This resolves bug 2927 Signed-off-by: Ray Vine <ray-v@inbox.lv> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88afefe..37f88e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -301,7 +301,7 @@ tde_add_library( tdevncclient STATIC_PIC AUTOMOC
SOURCES
${LIBVNCCLIENT_SOURCES}
LINK
- ${ADDITIONAL_LIBS} ${ZLIB_LIBRARIES} ${JPEG_LIBRARIES} ${GNUTLS_LIBRARIES}
+ pthread ${ADDITIONAL_LIBS} ${ZLIB_LIBRARIES} ${JPEG_LIBRARIES} ${GNUTLS_LIBRARIES} ${OPENSSL_LIBRARIES}
)
##### tdevncserver (static) ########################