summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2018-07-26 11:14:03 +0200
committerChristian Beier <dontmind@freeshell.org>2018-07-30 19:15:13 +0200
commitbfdb850bfb73ac08146fb7a5d4415c91116eccda (patch)
tree0ab4de84de43147fa49f34d646aeb1c62e6ca919 /CMakeLists.txt
parent8f1b565dbeab0afd2965ef2fe8af86aabb1275dc (diff)
downloadlibtdevnc-bfdb850bfb73ac08146fb7a5d4415c91116eccda.tar.gz
libtdevnc-bfdb850bfb73ac08146fb7a5d4415c91116eccda.zip
SDLvncviewer: use SDL2 for clipboard handling
By using this, we can get rid of our own homebrewn solution scrap.[c|h] and drop X11 from the build system.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c831ee9..86038d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,6 @@ option(WITH_ZLIB "Search for the zlib compression library to support additional
option(WITH_JPEG "Search for the libjpeg compression library to support additional encodings" ON)
option(WITH_PNG "Search for the PNG compression library to support additional encodings" ON)
option(WITH_SDL "Search for the Simple Direct Media Layer library to build an example SDL vnc client" ON)
-option(WITH_X11 "Search for X11 to build the example SDL vnc client with clipboard support" ON)
option(WITH_THREADS "Search for a threading library to build with multithreading support" ON)
option(WITH_GNUTLS "Search for the GnuTLS secure communications library to support encryption" ON)
option(WITH_OPENSSL "Search for the OpenSSL cryptography library to support encryption" ON)
@@ -105,11 +104,6 @@ if(WITH_SDL)
endif(WITH_SDL)
-if(WITH_X11)
- find_package(X11)
-endif(WITH_X11)
-
-
if(WITH_THREADS)
find_package(Threads)
endif(WITH_THREADS)
@@ -506,7 +500,6 @@ if(SDL2_FOUND)
${LIBVNCCLIENT_EXAMPLES}
SDLvncviewer
)
- set(SDLvncviewer_EXTRA_SOURCES scrap.c)
endif(SDL2_FOUND)
if(FFMPEG_FOUND)
@@ -530,7 +523,7 @@ foreach(e ${LIBVNCCLIENT_EXAMPLES})
add_executable(client_examples_${e} ${LIBVNCCLIEXAMPLE_DIR}/${e}.c ${LIBVNCCLIEXAMPLE_DIR}/${${e}_EXTRA_SOURCES} )
set_target_properties(client_examples_${e} PROPERTIES OUTPUT_NAME ${e})
set_target_properties(client_examples_${e} PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/client_examples)
- target_link_libraries(client_examples_${e} vncclient ${CMAKE_THREAD_LIBS_INIT} ${SDL2_LIBRARY} ${X11_LIBRARIES} ${FFMPEG_LIBRARIES})
+ target_link_libraries(client_examples_${e} vncclient ${CMAKE_THREAD_LIBS_INIT} ${SDL2_LIBRARY} ${FFMPEG_LIBRARIES})
endforeach(e ${LIBVNCCLIENT_EXAMPLES})