summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2017-03-26 16:29:55 +0200
committerChristian Beier <dontmind@freeshell.org>2017-03-26 16:29:55 +0200
commitef971860233a9abfe66533381e82ed094815a83f (patch)
tree4f04b7e4843617de02566f161770a68836b83e0c /CMakeLists.txt
parent80ad74f7613d7d790a5152ee377af361ecd3ff9b (diff)
downloadlibtdevnc-ef971860233a9abfe66533381e82ed094815a83f.tar.gz
libtdevnc-ef971860233a9abfe66533381e82ed094815a83f.zip
CMake: automatically build androidvncserver when crosscompiling for Android
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f20b4dc..d39672e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -431,6 +431,13 @@ if(MACOS)
)
endif(MACOS)
+if(ANDROID)
+ set(LIBVNCSERVER_EXAMPLES
+ ${LIBVNCSERVER_EXAMPLES}
+ androidvncserver
+ )
+endif(ANDROID)
+
set(LIBVNCCLIENT_EXAMPLES
backchannel
ppmtest