summaryrefslogtreecommitdiffstats
path: root/VisualNaCro/configure.ac
diff options
context:
space:
mode:
authordscho <dscho>2006-09-12 15:53:11 +0000
committerdscho <dscho>2006-09-12 15:53:11 +0000
commit9b93f295e90b4d8560068bda8659617f4754a88f (patch)
tree8dd94474ac80c77368e718e75881d9176aa80db2 /VisualNaCro/configure.ac
parent6dd263946ebb9cf1e10151d29d229ed523d490e0 (diff)
downloadlibtdevnc-9b93f295e90b4d8560068bda8659617f4754a88f.tar.gz
libtdevnc-9b93f295e90b4d8560068bda8659617f4754a88f.zip
fix compilation with cygwin
Diffstat (limited to 'VisualNaCro/configure.ac')
-rw-r--r--VisualNaCro/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/VisualNaCro/configure.ac b/VisualNaCro/configure.ac
index 0fc6e8c..582a291 100644
--- a/VisualNaCro/configure.ac
+++ b/VisualNaCro/configure.ac
@@ -62,7 +62,7 @@ then
*-*-aix*) LDSHARED="\$(srcdir)/ld_so_aix \$(CC)";;
*-*-cygwin* | *-*-mingw*)
if test "$GCC" = yes; then
- LDSHARED="$CC -shared"
+ LDSHARED="dllwrap --driver-name gcc --dlltool dlltool --export-all-symbols --as as --dllname \$(LIBPREFIX)\$(TARGET)\$(SO)"
else
if test "cl" = $CC ; then
# Microsoft Visual C++ (MSVC)