summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrunge <runge@karlrunge.com>2010-12-21 14:31:15 -0500
committerrunge <runge@karlrunge.com>2010-12-21 14:31:15 -0500
commit0c03b989407f9e5ea66b403011baaaad09fcd536 (patch)
treeaca391111c054b205ce52edb3b3f2df6f895b04e /configure.ac
parent365a22c63cb292ea494f39ebc48a37e322e5eb14 (diff)
downloadlibtdevnc-0c03b989407f9e5ea66b403011baaaad09fcd536.tar.gz
libtdevnc-0c03b989407f9e5ea66b403011baaaad09fcd536.zip
x11vnc: force --with-system-libvncserver to use correct headers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7db854..1bdef8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -831,6 +831,20 @@ if test "$build_x11vnc" = "yes"; then
# configure.ac:690: required file `x11vnc/Makefile.in' not found
#
AC_CONFIG_FILES([x11vnc/Makefile x11vnc/misc/Makefile x11vnc/misc/turbovnc/Makefile])
+
+ if test ! -z "$with_system_libvncserver" -a "x$with_system_libvncserver" != "xno"; then
+ # need to move local tarball rfb headers aside:
+ hdrs="rfb.h rfbclient.h rfbproto.h rfbregion.h rfbint.h"
+ echo "with-system-libvncserver: moving aside headers $hdrs"
+ for hdr in $hdrs
+ do
+ if test -f "rfb/$hdr"; then
+ echo "with-system-libvncserver: moving rfb/$hdr to rfb/$hdr.ORIG"
+ mv rfb/$hdr rfb/$hdr.ORIG
+ fi
+ done
+ echo "with-system-libvncserver: *NOTE* move them back manually to start over."
+ fi
fi
AC_CONFIG_COMMANDS([chmod-libvncserver-config],[chmod a+x libvncserver-config])