summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrunge <runge>2004-08-04 03:11:03 +0000
committerrunge <runge>2004-08-04 03:11:03 +0000
commit2c668dea01e80aa55c5fd803c633b16845c649d9 (patch)
tree3233b0c5703908c94090c9bbda62be1678cba6e7 /configure.ac
parenta19a9de3e567b4eafd866706e81858edc58d00ed (diff)
downloadlibtdevnc-2c668dea01e80aa55c5fd803c633b16845c649d9.tar.gz
libtdevnc-2c668dea01e80aa55c5fd803c633b16845c649d9.zip
fix XKBlib.h detection on *BSD, x11vnc: manpage and README
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9c2d1f..2afd0e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,8 +42,11 @@ AC_PATH_XTRA
AH_TEMPLATE(HAVE_XKEYBOARD, [XKEYBOARD extension build environment present])
AH_TEMPLATE(HAVE_LIBXINERAMA, [XINERAMA extension build environment present])
if test "$X_CFLAGS" != "-DX_DISPLAY_MISSING"; then
+ saved_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
AC_CHECK_HEADER(X11/XKBlib.h, HAVE_XKBLIB_H="true",
HAVE_XKBLIB_H="false", [#include <X11/Xlib.h>])
+ CPPFLAGS="$saved_CPPFLAGS"
if test $HAVE_XKBLIB_H = "true"; then
AC_CHECK_LIB(X11, XkbSelectEvents,
[AC_DEFINE(HAVE_XKEYBOARD)], ,