summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVic Lee <llyzs@163.com>2009-10-01 20:22:36 +0800
committerJohannes Schindelin <johannes.schindelin@gmx.de>2009-10-02 11:52:05 +0200
commit58a8df6ff2bffa46d96b057603c93d824f1c8591 (patch)
tree22b343f454cd04530de84d42320aa1d390a602ea /configure.ac
parent0c061f2a2757384fb4f43c2462f649a1ba5a6c9e (diff)
downloadlibtdevnc-58a8df6ff2bffa46d96b057603c93d824f1c8591.tar.gz
libtdevnc-58a8df6ff2bffa46d96b057603c93d824f1c8591.zip
Add anonymous TLS support in libvncclient
Signed-off-by: Vic Lee <llyzs@163.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65e258c..7b45157 100644
--- a/configure.ac
+++ b/configure.ac
@@ -667,6 +667,22 @@ if test ! -z "$MINGW"; then
fi
AC_SUBST(WSOCKLIB)
+# Checks for GnuTLS
+AH_TEMPLATE(WITH_CLIENT_TLS, [Enable support for gnutls in libvncclient])
+AC_ARG_WITH(gnutls,
+[ --without-gnutls disable support for gnutls],,)
+AC_ARG_WITH(client-tls,
+[ --without-client-tls disable support for gnutls in libvncclient],,)
+
+if test "x$with_gnutls" != "xno"; then
+ PKG_CHECK_MODULES(GNUTLS, gnutls >= 2.8.0)
+ CFLAGS="$CFLAGS $GNUTLS_CFLAGS"
+ LIBS="$LIBS $GNUTLS_LIBS"
+ if test "x$with_client_tls" != "xno"; then
+ AC_DEFINE(WITH_CLIENT_TLS)
+ fi
+fi
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h sys/timeb.h syslog.h unistd.h])