summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrunge <runge>2005-05-03 02:05:51 +0000
committerrunge <runge>2005-05-03 02:05:51 +0000
commitb0daa444cc2fdda15b8b82497d17f80e7d75f8ad (patch)
tree6702f27b14532de86c6c31dc5a95c00e0f95b160 /configure.ac
parent6602a22f2b3e1164bf521868063891ef62b3650f (diff)
downloadlibtdevnc-b0daa444cc2fdda15b8b82497d17f80e7d75f8ad.tar.gz
libtdevnc-b0daa444cc2fdda15b8b82497d17f80e7d75f8ad.zip
x11vnc: -scrollcopyrect/RECORD, etc. configure.ac: customizations for x11vnc pkg
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 41 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd31883..9f2299d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,7 @@ AH_TEMPLATE(HAVE_LIBXRANDR, [XRANDR extension build environment present])
AH_TEMPLATE(HAVE_LIBXFIXES, [XFIXES extension build environment present])
AH_TEMPLATE(HAVE_LIBXDAMAGE, [XDAMAGE extension build environment present])
AH_TEMPLATE(HAVE_LIBXTRAP, [DEC-XTRAP extension build environment present])
+AH_TEMPLATE(HAVE_RECORD, [RECORD extension build environment present])
if test "$X_CFLAGS" != "-DX_DISPLAY_MISSING"; then
AC_CHECK_LIB(X11, XGetImage, HAVE_X="true",
HAVE_X="false",
@@ -74,6 +75,11 @@ if test "$X_CFLAGS" != "-DX_DISPLAY_MISSING"; then
[AC_DEFINE(HAVE_XTEST)], ,
$X_LIBS $X_PRELIBS -lX11 $X_EXTRA_LIBS)
+ AC_CHECK_LIB(Xtst, XRecordEnableContextAsync,
+ X_PRELIBS="$X_PRELIBS -lXtst"
+ [AC_DEFINE(HAVE_RECORD)], ,
+ $X_LIBS $X_PRELIBS -lX11 $X_EXTRA_LIBS)
+
# we use XTRAP on X11R5, or user can set X11VNC_USE_XTRAP
if test ! -z "$X11VNC_USE_XTRAP" -o -z "$HAVE_XTESTGRABCONTROL"; then
AC_CHECK_LIB(XTrap, XETrapSetGrabServer,
@@ -131,6 +137,19 @@ fi
AC_SUBST(X_LIBS)
AM_CONDITIONAL(HAVE_X, test $HAVE_X != "false")
+if test "$PACKAGE_NAME" = "x11vnc" -a $HAVE_X = "false"; then
+ AC_MSG_ERROR([
+==========================================================================
+a working X window system build environment is required to build x11vnc.
+Make sure any required X development packages are installed. If they are
+installed in non-standard locations, one can use the --x-includes=DIR
+and --x-libraries=DIR configure options or set the CPPFLAGS and LDFLAGS
+environment variables to indicate where the X window system header files
+and libraries may be found.
+==========================================================================
+])
+fi
+
# Checks for libraries.
AC_ARG_WITH(jpeg,
@@ -168,6 +187,17 @@ if test "x$with_jpeg" != "xno"; then
LDFLAGS="$saved_LDFLAGS"
fi
fi
+ if test "$PACKAGE_NAME" = "x11vnc"; then
+ if test "x$HAVE_JPEGLIB_H" != "xtrue"; then
+ AC_MSG_WARN([
+libjpeg compression library was not found: this may lead to reduced performance
+especially over slow links. If libjpeg is in a non-standard location
+use --with-jpeg=DIR to indicate the header file is in DIR/include/jpeglib.h
+and the library in DIR/lib/libjpeg.a. A copy of libjpeg may be obtained
+from: ftp://ftp.uu.net/graphics/jpeg/
+])
+ fi
+ fi
fi
AC_ARG_WITH(libz,
@@ -198,6 +228,17 @@ if test "x$with_zlib" != "xno" -a "x$with_libz" != "xno"; then
LDFLAGS="$saved_LDFLAGS"
fi
fi
+ if test "$PACKAGE_NAME" = "x11vnc"; then
+ if test "x$HAVE_ZLIB_H" != "xtrue"; then
+ AC_MSG_WARN([
+libz compression library was not found: this may lead to reduced performance,
+especially over slow links. If libz is in a non-standard location
+use --with-zlib=DIR to indicate the header file is in DIR/include/zlib.h
+and the library in DIR/lib/libz.a. A copy of libz may be obtained
+from: http://www.gzip.org/zlib/
+])
+ fi
+ fi
fi
AC_CHECK_HEADER(pthread.h, HAVE_PTHREAD_H="true")