summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authordscho <dscho>2004-06-07 08:31:57 +0000
committerdscho <dscho>2004-06-07 08:31:57 +0000
commit2b8c2a5c3a71364e402b4df334a6f5aff5ed77a9 (patch)
tree66e59b58f919f5848780d5c7d6c954160e289cff /test/Makefile.am
parent98e4f89569587c143a56e4dcf8162a035efc361e (diff)
downloadlibtdevnc-2b8c2a5c3a71364e402b4df334a6f5aff5ed77a9.tar.gz
libtdevnc-2b8c2a5c3a71364e402b4df334a6f5aff5ed77a9.zip
add client_examples/, add SDLvncviewer, libvncclient API changes, suppress automake CFLAGS nagging
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1ca7941..33839d5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,6 +1,13 @@
-CFLAGS=-I.. -g -Wall
+DEFINES=-I.. -g -Wall
+
+if HAVE_LIBPTHREAD
+BACKGROUND_TEST=blooptest
+endif
+
+copyrecttest_LDADD=$(LDADD) -lm
+
+noinst_PROGRAMS=tight-1 cargstest copyrecttest $(BACKGROUND_TEST)
-noinst_PROGRAMS=tight-1 cargstest
LDADD = ../libvncserver/libvncserver.a ../libvncclient/libvncclient.a