summaryrefslogtreecommitdiffstats
path: root/client_examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client_examples/Makefile.am')
-rw-r--r--client_examples/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/client_examples/Makefile.am b/client_examples/Makefile.am
index d2a3e29..83750ab 100644
--- a/client_examples/Makefile.am
+++ b/client_examples/Makefile.am
@@ -1,6 +1,15 @@
DEFINES=-I.. -g -Wall
LDADD = ../libvncclient/libvncclient.a
+if WITH_FFMPEG
+FFMPEG_HOME=@with_ffmpeg@
+
+vnc2mpg_CFLAGS=-I$(FFMPEG_HOME)/libavformat -I$(FFMPEG_HOME)/libavcodec
+vnc2mpg_LDADD=$(LDADD) $(FFMPEG_HOME)/libavformat/libavformat.a $(FFMPEG_HOME)/libavcodec/libavcodec.a -lm
+
+FFMPEG_CLIENT=vnc2mpg
+endif
+
if HAVE_LIBSDL
SDLVIEWER=SDLvncviewer
@@ -9,5 +18,7 @@ SDLvncviewer_CFLAGS=`sdl-config --cflags`
SDLvncviewer_LDFLAGS=`sdl-config --libs`
endif
-noinst_PROGRAMS=ppmtest $(SDLVIEWER)
+noinst_PROGRAMS=ppmtest $(SDLVIEWER) $(FFMPEG_CLIENT)
+
+