summaryrefslogtreecommitdiffstats
path: root/client_examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client_examples/Makefile.am')
-rw-r--r--client_examples/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/client_examples/Makefile.am b/client_examples/Makefile.am
index 8619dc2..2779d53 100644
--- a/client_examples/Makefile.am
+++ b/client_examples/Makefile.am
@@ -28,7 +28,15 @@ endif
SDLvncviewer_LDADD=$(LDADD) $(SDL_LIBS) $(X11_LIB)
endif
-noinst_PROGRAMS=ppmtest $(SDLVIEWER) $(FFMPEG_CLIENT) backchannel
+if HAVE_LIBGTK
+GTKVIEWER=gtkvncviewer
+gtkvncviewer_SOURCES=gtkvncviewer.c
+gtkvncviewer_CFLAGS=$(GTK_CFLAGS)
+gtkvncviewer_LDADD=$(LDADD) $(GTK_LIBS)
+endif
+
+
+noinst_PROGRAMS=ppmtest $(SDLVIEWER) $(GTKVIEWER) $(FFMPEG_CLIENT) backchannel