summaryrefslogtreecommitdiffstats
path: root/src/metadata/trueaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-11-13 18:42:43 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-11-14 23:18:41 +0900
commit5bba09ee4570e1227de99565d41ae9fb6bc14ae1 (patch)
tree29d378b82102f1de620ee07a8167d569f7f031d7 /src/metadata/trueaudio/CMakeLists.txt
parent546952a11f82de4741f508f401ab613c172ad293 (diff)
downloadsoundkonverter-5bba09ee.tar.gz
soundkonverter-5bba09ee.zip
cmake conversion
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 802b45c5566c3916e46250060ecef332f055fc26)
Diffstat (limited to 'src/metadata/trueaudio/CMakeLists.txt')
-rw-r--r--src/metadata/trueaudio/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/metadata/trueaudio/CMakeLists.txt b/src/metadata/trueaudio/CMakeLists.txt
new file mode 100644
index 0000000..dbbd851
--- /dev/null
+++ b/src/metadata/trueaudio/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${TAGLIB_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### pluginloader
+
+tde_add_library( tagtrueaudio STATIC_PIC AUTOMOC
+ SOURCES ttafile.cpp ttaproperties.cpp taglib_trueaudiofiletyperesolver.cpp
+)