summaryrefslogtreecommitdiffstats
path: root/src/metadata/trueaudio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/metadata/trueaudio/CMakeLists.txt')
-rw-r--r--src/metadata/trueaudio/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/metadata/trueaudio/CMakeLists.txt b/src/metadata/trueaudio/CMakeLists.txt
new file mode 100644
index 0000000..dbbd851
--- /dev/null
+++ b/src/metadata/trueaudio/CMakeLists.txt
@@ -0,0 +1,20 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${TAGLIB_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### pluginloader
+
+tde_add_library( tagtrueaudio STATIC_PIC AUTOMOC
+ SOURCES ttafile.cpp ttaproperties.cpp taglib_trueaudiofiletyperesolver.cpp
+)