summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdenetwork-doc
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-09 03:42:17 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:33:33 +0000
commit42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083 (patch)
tree8399b125f010029c9271f77d7af26a6f83f2d482 /trinity-base/tdenetwork-doc
parent13f3b6432f125802f4fee3827d2b0e882a0a8dfe (diff)
downloadtde-packaging-gentoo-42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083.tar.gz
tde-packaging-gentoo-42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 4.
This time: amor, eyesapplet, fifteenapplet, kdict, kget, kmoon, knewsticker, kodo, kopete, kpf, kppp, krdc, krfb, ksirc, ktalkd, kteatime, ktux, kweather, kwifimanager, kworldclock, lisa, tdednssd, tdenetwork-doc, tdenetwork-filesharing, tdenetwork-meta, tdenetwork-tdefile-plugins, tdetoys-doc, and tdetoys-meta Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-base/tdenetwork-doc')
-rw-r--r--trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild b/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild
index bb0e4a14..c49d3ef5 100644
--- a/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild
+++ b/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdenetwork-derived packages"
-DESCRIPTION="Documentaion for kdegraphics-derived packages"
-KEYWORDS=
-IUSE=""
RDEPEND="
- >=trinity-base/khelpcenter-${PV}:${SLOT}"
+ =trinity-base/khelpcenter-${PV}"
pkg_setup() {
- # we should reduce MAKEOPTS -j parametr to no more than 4
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
local makeopts_j
makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
- export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
- ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
fi
- trinity-meta_pkg_setup
+ trinity-meta-2_pkg_setup
}