summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tde-guidance/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-04-04 03:02:11 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-04-04 15:53:01 +0200
commit3d0fe45a7b0b586d096644a3581df8307787eb3a (patch)
treef6e05af72fa60089c8db1e9999d982d47be07bc8 /debian/_base/applications/tde-guidance/debian/rules
parent5d067f8a1c69ffd2585cd3a46f0601cc552e40d2 (diff)
downloadtde-packaging-3d0fe45a7b0b586d096644a3581df8307787eb3a.tar.gz
tde-packaging-3d0fe45a7b0b586d096644a3581df8307787eb3a.zip
DEB: Move DEB_DH_BUILDDEB_ARGS to common cdbs rules.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/applications/tde-guidance/debian/rules')
-rwxr-xr-xdebian/_base/applications/tde-guidance/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/_base/applications/tde-guidance/debian/rules b/debian/_base/applications/tde-guidance/debian/rules
index 0cbf1123b..54328b46d 100755
--- a/debian/_base/applications/tde-guidance/debian/rules
+++ b/debian/_base/applications/tde-guidance/debian/rules
@@ -22,8 +22,15 @@ PYSUPPORT_PATH = $(DEB_DESTDIR)$(PYSUPPORT_INST_PATH)
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
LDFLAGS_APPEND := -L/opt/trinity/lib
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
post-patches::
# make sure that python binary exists