summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Andriot <francois.andriot@free.fr>2013-05-05 04:50:18 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-05-05 04:50:18 +0200
commit2b6bc47289c47d4c5322ac25b688d0b3027a31d0 (patch)
tree930adb699da2e0257033c4052bcedbfabc5768a0 /CMakeLists.txt
parent8bdb01112167d8d83b75353064c3c94a1a1c27a8 (diff)
downloadtdebase-2b6bc47289c47d4c5322ac25b688d0b3027a31d0.tar.gz
tdebase-2b6bc47289c47d4c5322ac25b688d0b3027a31d0.zip
Added support for makewhatis in tdeio-man
This resolves Bug 714
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0810f94ea..9ff608393 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,6 +269,16 @@ if( BUILD_STARTTDE )
endif()
+##### Determine whether older manpage support is used ##########
+
+if( EXISTS "/usr/sbin/makewhatis" )
+ set( WITH_MAKEWHATIS "1" )
+ message( STATUS "Selected makewhatis for tdeio-man on your system" )
+else()
+ message( STATUS "Selected man-db for tdeio-man on your system" )
+endif()
+
+
##### write configure files #####################
configure_file( config.h.cmake config.h @ONLY )