summaryrefslogtreecommitdiffstats
path: root/kcontrol/konq/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-26 11:36:35 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /kcontrol/konq/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kcontrol/konq/CMakeLists.txt')
-rw-r--r--kcontrol/konq/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/kcontrol/konq/CMakeLists.txt b/kcontrol/konq/CMakeLists.txt
index 3e99e5f27..019520a19 100644
--- a/kcontrol/konq/CMakeLists.txt
+++ b/kcontrol/konq/CMakeLists.txt
@@ -23,19 +23,24 @@ link_directories(
##### other data ################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
desktopbehavior.desktop desktop.desktop
desktoppath.desktop filebrowser.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+ PO_DIR kcontrol-desktops
+)
install( FILES
overlapping.png onlyone.png
DESTINATION ${DATA_INSTALL_DIR}/kcontrol/pics )
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
filebehavior.desktop fileappearance.desktop
filepreviews.desktop
- DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR kcontrol-desktops
+)
##### kcm_konq (module) #########################