summaryrefslogtreecommitdiffstats
path: root/kioslave/remote/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kioslave/remote/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kioslave/remote/Makefile.am')
-rw-r--r--kioslave/remote/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kioslave/remote/Makefile.am b/kioslave/remote/Makefile.am
new file mode 100644
index 000000000..073bfd12e
--- /dev/null
+++ b/kioslave/remote/Makefile.am
@@ -0,0 +1,32 @@
+SUBDIRS= . kdedmodule
+# wizard
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kio_remote.la
+
+kio_remote_la_SOURCES = dummy.cpp
+kio_remote_la_LIBADD = libkioremote.la $(LIB_KIO)
+kio_remote_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+
+dummy.cpp:
+ echo > dummy.cpp
+
+kde_services_DATA = remote.protocol
+
+noinst_LTLIBRARIES = libkioremote.la
+libkioremote_la_SOURCES = kio_remote.cpp remoteimpl.cpp
+
+check_PROGRAMS = testremote
+testremote_SOURCES = testremote.cpp
+testremote_LDADD = libkioremote.la $(LIB_KIO)
+testremote_LDFLAGS = $(all_libraries)
+
+## TODO in unsermake: TESTS = testremote
+check: testremote
+ ./testremote
+
+messages:
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp" -o -name "*.h"` -o $(podir)/kio_remote.pot
+