summaryrefslogtreecommitdiffstats
path: root/kstart/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit4aed2c8219774f5d797760606b8489a92ddc5163 (patch)
tree3f8c130f7d269626bf6a9447407ef6c35954426a /kstart/Makefile.am
downloadtdebase-4aed2c8219774f5d797760606b8489a92ddc5163.tar.gz
tdebase-4aed2c8219774f5d797760606b8489a92ddc5163.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebase@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kstart/Makefile.am')
-rw-r--r--kstart/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kstart/Makefile.am b/kstart/Makefile.am
new file mode 100644
index 000000000..01aeca492
--- /dev/null
+++ b/kstart/Makefile.am
@@ -0,0 +1,21 @@
+####### Fiddle here
+
+AM_CPPFLAGS = -DQT_NO_CAST_ASCII -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT
+
+INCLUDES = $(all_includes)
+
+####### Files
+
+bin_PROGRAMS = kstart
+kstart_SOURCES = kstart.cpp
+kstart_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kstart_LDADD = $(LIB_KDECORE)
+METASOURCES = kstart.moc
+
+noinst_HEADERS = kstart.h version.h
+
+messages:
+ $(XGETTEXT) $(kstart_SOURCES) -o $(podir)/kstart.pot
+
+EXTRA_DIST = CHANGES LICENSE.readme
+