summaryrefslogtreecommitdiffstats
path: root/tdeioslave/filter/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
commitde7e5867a65e0a46f1388e3e50bc7eeddd1aecbf (patch)
treedbb3152c372f8620f9290137d461f3d9f9eba1cb /tdeioslave/filter/Makefile.am
parent936d3cec490c13f2c5f7dd14f5e364fddaa6da71 (diff)
downloadtdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.tar.gz
tdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/filter/Makefile.am')
-rw-r--r--tdeioslave/filter/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tdeioslave/filter/Makefile.am b/tdeioslave/filter/Makefile.am
new file mode 100644
index 000000000..f315064c8
--- /dev/null
+++ b/tdeioslave/filter/Makefile.am
@@ -0,0 +1,21 @@
+KDE_CPPFLAGS = -DQT_NO_CAST_ASCII
+
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = kio_filter.la
+
+kio_filter_la_SOURCES = filter.cc
+kio_filter_la_LIBADD = $(LIB_KSYCOCA)
+kio_filter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+noinst_HEADERS = filter.h
+
+METASOURCES = AUTO
+
+protocoldir = $(kde_servicesdir)
+
+if include_BZIP2
+BZIP2FILES=bzip.protocol bzip2.protocol
+endif
+
+protocol_DATA = gzip.protocol $(BZIP2FILES)
+