summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/tiff/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:03:37 -0600
commit2e25fa39cd67cca2472d3eabdb478feb517d72a5 (patch)
tree63725962f632d152cbf20709191d39f6fc865966 /tdefile-plugins/tiff/Makefile.am
parent190d88dfc662f3fc466c9d1f53acbbea65f33c49 (diff)
downloadtdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.tar.gz
tdegraphics-2e25fa39cd67cca2472d3eabdb478feb517d72a5.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdefile-plugins/tiff/Makefile.am')
-rw-r--r--tdefile-plugins/tiff/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tdefile-plugins/tiff/Makefile.am b/tdefile-plugins/tiff/Makefile.am
new file mode 100644
index 00000000..9807a66c
--- /dev/null
+++ b/tdefile-plugins/tiff/Makefile.am
@@ -0,0 +1,21 @@
+## Makefile.am for Tiff file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+noinst_HEADERS = tdefile_tiff.h
+
+kde_module_LTLIBRARIES = tdefile_tiff.la
+
+tdefile_tiff_la_SOURCES = tdefile_tiff.cpp
+tdefile_tiff_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_tiff_la_LIBADD = $(LIB_KIO) $(LIBTIFF)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdefile_tiff.pot
+
+services_DATA = tdefile_tiff.desktop
+servicesdir = $(kde_servicesdir)