summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-07-07 22:21:21 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-07-07 22:40:46 +0900
commit7214a7b6b590d62aac622dbf2de31b1ca1ba78d5 (patch)
treee63d5e40e1a2d4d4a8efb0990ebff10dcf163617 /CMakeLists.txt
parentc76553c4fb3ee8f839c17b4dc3c3beb3c4338eb3 (diff)
downloadtdelibs-7214a7b6b590d62aac622dbf2de31b1ca1ba78d5.tar.gz
tdelibs-7214a7b6b590d62aac622dbf2de31b1ca1ba78d5.zip
tdehw: code restructuring for tdestoragedevice.
1. added disk helper source files 2. removed WITH_UDISKS2, WITH_UDISK, WITH_UDEVIL defines. The respective code is always included 3. order of execution for mount/umount activities: udisks2, udisk, udevil, pmount. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b3541bde..a35aa8bf1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,9 +92,6 @@ OPTION( WITH_HAL "Enable HAL support" OFF )
OPTION( WITH_DEVKITPOWER "Enable DeviceKit Power support" OFF )
OPTION( WITH_LOGINDPOWER "Enable Logind/Systemd Power support" OFF )
OPTION( WITH_UPOWER "Enable uPower support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UDISKS "Enable uDisks support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UDISKS2 "Enable uDisks2 support" ${WITH_ALL_OPTIONS} )
-OPTION( WITH_UDEVIL "Enable udevil support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_CONSOLEKIT "Enable ConsoleKit support" ${WITH_ALL_OPTIONS} )
OPTION( WITH_NETWORK_MANAGER_BACKEND "Enable network-manager support" OFF )
OPTION( WITH_SUDO_TDESU_BACKEND "Use sudo as backend for tdesu (default is su)" OFF )