summaryrefslogtreecommitdiffstats
path: root/interfaces/tdetexteditor/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /interfaces/tdetexteditor/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'interfaces/tdetexteditor/CMakeLists.txt')
-rw-r--r--interfaces/tdetexteditor/CMakeLists.txt22
1 files changed, 15 insertions, 7 deletions
diff --git a/interfaces/tdetexteditor/CMakeLists.txt b/interfaces/tdetexteditor/CMakeLists.txt
index a9cdba751..5438c85e1 100644
--- a/interfaces/tdetexteditor/CMakeLists.txt
+++ b/interfaces/tdetexteditor/CMakeLists.txt
@@ -51,15 +51,23 @@ install( FILES
##### other data ################################
-install( FILES
- tdetexteditor.desktop tdetexteditoreditor.desktop
+foreach( _service
+ tdetexteditor.desktop
+ tdetexteditoreditor.desktop
tdetexteditorplugin.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
-
-install( FILES
- kcm_tdetexteditor.desktop
- DESTINATION ${DATA_INSTALL_DIR}/kcm_componentchooser )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_service}
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+ )
+endforeach()
+tde_create_translated_desktop(
+ SOURCE kcm_tdetexteditor.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kcm_componentchooser
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)
##### tdetexteditor ###############################