summaryrefslogtreecommitdiffstats
path: root/kio/misc/kpac/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /kio/misc/kpac/Makefile.am
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kio/misc/kpac/Makefile.am')
-rw-r--r--kio/misc/kpac/Makefile.am30
1 files changed, 0 insertions, 30 deletions
diff --git a/kio/misc/kpac/Makefile.am b/kio/misc/kpac/Makefile.am
deleted file mode 100644
index beb6a4b86..000000000
--- a/kio/misc/kpac/Makefile.am
+++ /dev/null
@@ -1,30 +0,0 @@
-
-kde_module_LTLIBRARIES = kded_proxyscout.la
-bin_PROGRAMS = kpac_dhcp_helper
-
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/libltdl -I$(top_srcdir)/kded -I$(top_builddir)/kjs \
- -I$(top_srcdir)/tdecore/network $(all_includes)
-METASOURCES = AUTO
-KDE_CXXFLAGS = $(USE_EXCEPTIONS)
-
-kded_proxyscout_la_SOURCES = proxyscout.skel proxyscout.cpp script.cpp \
- downloader.cpp discovery.cpp
-kded_proxyscout_la_LDFLAGS = $(all_libraries) -module -avoid-version
-kded_proxyscout_la_LIBADD = $(LIB_KIO) $(top_builddir)/kjs/libkjs.la $(LIB_KDED) $(LIB_QT) \
- $(top_builddir)/dcop/libDCOP.la $(LIB_TDECORE) $(LIBRESOLV)
-
-kpac_dhcp_helper_SOURCES = kpac_dhcp_helper.c
-kpac_dhcp_helper_CFLAGS = $(KDE_USE_FPIE)
-kpac_dhcp_helper_LDFLAGS = $(KDE_USE_PIE)
-kpac_dhcp_helper_LDADD = $(LIBSOCKET)
-
-noinst_HEADERS = proxyscout.h script.h downloader.h discovery.h
-
-servicesdir = $(kde_servicesdir)/kded
-services_DATA = proxyscout.desktop
-
-proxyscoutdatadir = $(kde_datadir)/proxyscout
-proxyscoutdata_DATA = eventsrc
-
-install-exec-local:
- @(chown root $(DESTDIR)$(bindir)/kpac_dhcp_helper && chmod 4755 $(DESTDIR)$(bindir)/kpac_dhcp_helper) || echo "Please make kpac_dhcp_helper setuid root"