summaryrefslogtreecommitdiffstats
path: root/kspell2/plugins/aspell/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kspell2/plugins/aspell/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kspell2/plugins/aspell/Makefile.am')
-rw-r--r--kspell2/plugins/aspell/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kspell2/plugins/aspell/Makefile.am b/kspell2/plugins/aspell/Makefile.am
new file mode 100644
index 000000000..69f560ec1
--- /dev/null
+++ b/kspell2/plugins/aspell/Makefile.am
@@ -0,0 +1,17 @@
+METASOURCES = AUTO
+
+AM_CPPFLAGS = -I$(top_srcdir)/kspell2 -I$(top_srcdir) $(all_includes)
+
+# For the future: examine if condensing the tons of *_LDFLAGS variables
+# into $(all_libraries) isn't better
+AM_LDFLAGS = $(LDFLAGS_AS_NEEDED) $(LDFLAGS_NEW_DTAGS)
+
+kde_module_LTLIBRARIES = kspell_aspell.la
+
+kspell_aspell_la_SOURCES = kspell_aspellclient.cpp kspell_aspelldict.cpp
+
+kspell_aspell_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN)
+kspell_aspell_la_LIBADD = ../../ui/libkspell2.la -laspell
+
+service_DATA = kspell_aspell.desktop
+servicedir = $(kde_servicesdir)