summaryrefslogtreecommitdiffstats
path: root/mimetypes/model/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /mimetypes/model/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'mimetypes/model/CMakeLists.txt')
-rw-r--r--mimetypes/model/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/mimetypes/model/CMakeLists.txt b/mimetypes/model/CMakeLists.txt
index b101c70aa..49c21f98b 100644
--- a/mimetypes/model/CMakeLists.txt
+++ b/mimetypes/model/CMakeLists.txt
@@ -11,6 +11,12 @@
##### other data ################################
-install( FILES
+foreach( _mimetype
vrml.desktop
- DESTINATION ${MIME_INSTALL_DIR}/model )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_mimetype}
+ DESTINATION ${MIME_INSTALL_DIR}/model
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/mimetypes
+ )
+endforeach()