summaryrefslogtreecommitdiffstats
path: root/networkstatus/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-09-04 17:53:12 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-09-04 17:53:12 +0000
commitaf20635a2bb11eefabb627a2419644d3ac78831d (patch)
treea10097346376a69cf49288d3bd592b635a8744f9 /networkstatus/Makefile.am
parent84ae8923dff22da5912d9a322db515ce0a2388c7 (diff)
downloadtdelibs-af20635a2bb11eefabb627a2419644d3ac78831d.tar.gz
tdelibs-af20635a2bb11eefabb627a2419644d3ac78831d.zip
Added networkstatus service from pim to core for use in other network enabled applications
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1171617 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'networkstatus/Makefile.am')
-rw-r--r--networkstatus/Makefile.am46
1 files changed, 19 insertions, 27 deletions
diff --git a/networkstatus/Makefile.am b/networkstatus/Makefile.am
index 90c6891f3..c59aa55c6 100644
--- a/networkstatus/Makefile.am
+++ b/networkstatus/Makefile.am
@@ -2,44 +2,36 @@
METASOURCES = AUTO
-INCLUDES = -I$(top_srcdir)/kded -I$(top_srcdir) $(all_includes)
-
kde_module_LTLIBRARIES = kded_networkstatus.la
-
-kded_networkstatus_la_SOURCES = networkstatus.cpp networkstatus.skel \
- network.cpp
-kded_networkstatus_la_LIBADD = $(LIB_KDECORE) $(LIB_KIO) ./libnetworkstatus.la
-kded_networkstatus_la_LDFLAGS = $(all_libraries) -module -avoid-version
-
-servicesdir = $(kde_servicesdir)/kded
-
-services_DATA = networkstatus.desktop
-
lib_LTLIBRARIES = libnetworkstatus.la libconnectionmanager.la
libnetworkstatus_la_LIBADD = $(LIB_KDECORE)
libnetworkstatus_la_LDFLAGS = $(all_libraries)
libnetworkstatus_la_SOURCES = networkstatuscommon.cpp
-libconnectionmanager_la_LIBADD = $(LIB_KDECORE) libnetworkstatus.la
+libconnectionmanager_la_LIBADD = $(LIB_KDECORE)
libconnectionmanager_la_LDFLAGS = $(all_libraries)
-libconnectionmanager_la_SOURCES = connectionmanager.cpp connectionmanager_p.cpp networkstatusindicator.cpp connectionmanager.skel networkstatusiface.stub
+libconnectionmanager_la_SOURCES = connectionmanager.cpp connectionmanager.skel clientiface.stub
+
+INCLUDES = $(all_includes)
+
+kded_networkstatus_la_SOURCES = networkstatus.cpp networkstatus.skel \
+ clientiface.skel serviceiface.skel network.cpp
+#kclientiface.skel serviceiface.skel
+kded_networkstatus_la_LIBADD = $(LIB_KDECORE) $(LIB_KIO) ./libnetworkstatus.la
+kded_networkstatus_la_LDFLAGS = $(all_libraries) -module -avoid-version
-noinst_PROGRAMS = networkstatustestservice networkstatustestclient managedconnectiontestclient
+servicesdir = $(kde_servicesdir)/kded
+services_DATA = networkstatus.desktop
-networkstatustestservice_LDFLAGS = $(all_libraries)
-networkstatustestservice_LDADD = $(LIB_KFILE) libnetworkstatus.la
-networkstatustestservice_SOURCES = testservice.cpp testserviceview.ui networkstatusiface.stub
+noinst_HEADERS = serviceifaceimpl.h \
+ network.h clientifaceimpl.h testservice.h connectionmanager.h
-networkstatustestclient_LDFLAGS = $(all_libraries)
-networkstatustestclient_LDADD = $(LIB_KFILE) libnetworkstatus.la libconnectionmanager.la
-networkstatustestclient_SOURCES = testclient.cpp testclientview.ui
+include_HEADERS = serviceiface.h provideriface.h networkstatuscommon.h
-managedconnectiontestclient_LDFLAGS = $(all_libraries)
-managedconnectiontestclient_LDADD = $(LIB_KFILE) libnetworkstatus.la libconnectionmanager.la
-managedconnectiontestclient_SOURCES = testclient2.cpp testclientview.ui
+bin_PROGRAMS = networkstatustestservice
-noinst_HEADERS = network.h testservice.h testclient.h
+networkstatustestservice_LDFLAGS = $(all_libraries)
+networkstatustestservice_LDADD = libnetworkstatus.la
-include_HEADERS = networkstatuscommon.h connectionmanager.h networkstatusindicator.h \
- networkstatusiface.h
+networkstatustestservice_SOURCES = testservice.cpp provideriface.skel serviceiface.stub