summaryrefslogtreecommitdiffstats
path: root/tdehtml/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdehtml/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdehtml/CMakeLists.txt')
-rw-r--r--tdehtml/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/tdehtml/CMakeLists.txt b/tdehtml/CMakeLists.txt
index 5f6ce0f7e..8c50d736c 100644
--- a/tdehtml/CMakeLists.txt
+++ b/tdehtml/CMakeLists.txt
@@ -59,7 +59,14 @@ install( FILES
##### other data ################################
-install( FILES tdehtml.desktop tdehtmlimage.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+foreach( _service tdehtml.desktop tdehtmlimage.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_service}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdehtml-desktops
+ )
+endforeach()
+
install( FILES tdehtml.rc tdehtml_browser.rc tdehtml_popupmenu.rc DESTINATION ${DATA_INSTALL_DIR}/tdehtml )