summaryrefslogtreecommitdiffstats
path: root/tdehtml/html/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
commitdfe289850f068f19ba4a83ab4e7e22a7e09c13c9 (patch)
treec297348a55df66c571de4525646e0b9762427353 /tdehtml/html/CMakeLists.txt
parentb7658a0d5eca24a9d37c6e04f88298ef02389db0 (diff)
downloadtdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.tar.gz
tdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdehtml/html/CMakeLists.txt')
-rw-r--r--tdehtml/html/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/tdehtml/html/CMakeLists.txt b/tdehtml/html/CMakeLists.txt
new file mode 100644
index 000000000..a7a3bf466
--- /dev/null
+++ b/tdehtml/html/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/tdehtml
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+ ${CMAKE_SOURCE_DIR}/kio
+ ${CMAKE_SOURCE_DIR}/kio/kio
+ ${CMAKE_SOURCE_DIR}/kio/kfile
+ ${CMAKE_SOURCE_DIR}/kio/kssl
+ ${CMAKE_SOURCE_DIR}/tdeutils
+ ${CMAKE_SOURCE_DIR}/tdewallet/client
+)
+
+##### tdehtmlhtml-static ###########################
+
+set( target tdehtmlhtml )
+
+set( ${target}_SRCS
+ htmlparser.cpp htmltokenizer.cpp dtd.cpp html_headimpl.cpp
+ html_blockimpl.cpp html_elementimpl.cpp html_inlineimpl.cpp
+ html_documentimpl.cpp html_baseimpl.cpp html_imageimpl.cpp
+ html_listimpl.cpp html_miscimpl.cpp html_formimpl.cpp
+ html_objectimpl.cpp html_tableimpl.cpp
+)
+
+tde_add_library( ${target} STATIC_PIC AUTOMOC
+ SOURCES ${${target}_SRCS}
+)